When I add one layer to the map, open it in the print composer and add a scale bar the scale bar is fine. I can add layers (with the same CRS) and everything is fine.
Once there are two layers in my map and I open a new print composer and add a scale bar it comes out wrong (just a 0 with a line under it). This is still the case when using the same two layers that I had in the original print composer. Am I doing something wrong or is this a bug? Rachel

  • 1
    It works fine for me in version 1.9 Master. Can you state which version you are using. Also, I assume you've tried adjusting the number and size of segments for the second scale bar and ensuring it is associated with the correct map layer? – MappaGnosis Feb 1 '13 at 14:14
  • also check the scale of the map you are using in composition. the scale bar adjusts automatically. – Ger Feb 1 '13 at 14:43
  • Version 1.8.0 Lisboa. Yeah, I've tried figetting with all the settings it either works fine or not. If I try and change the settings it does change whats there but it doesn't create any segments no matter what I do. I've doing the same thing that I did earlier that worked and its not working now. Should I reinstall? – Rachel Feb 1 '13 at 14:48
  • Gerald, are you referring to the segment size and the map units per bar unit? If I change them the 0 changes, but it doesn't get any segments. – Rachel Feb 1 '13 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.