Am using Modis Reprojection Tool (ModisTool) on MODIS LST data (MOD11A1) to convert to GeoTiff format.

When I run it I get this error message:

Error: OpenGeoTIFFFILE: Opening Output Image File
Unable to open C:\(directory)\ ..LST_Day_1km.tif: Cannot open.

What is the correct syntax to use? Is there some way to debug this error?

  • 1
    Add the command you're calling to be able to help. – Peter Ivan Feb 1 '13 at 22:02
  • yes, it is because of the space in the path. much obliged! – chang Feb 18 '16 at 15:41

I just ran into the same problem, and somehow figured out the solution (in my case, at least): Make sure that there are no spaces in the path or name of your new file. For some reason, the MRT changes them to underscores instead of using quotes or whatever to keep them as spaces.

As I said, this worked for me (MRT 4.1, Mac OS X 10.8.2).

  • Maybe interesting, also in terms of the application of the QA map: pymodis.fem-environment.eu , a python library to work with MODIS data. – markusN Mar 18 '13 at 6:53

protected by PolyGeo Jul 19 '16 at 9:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.