How do I add .e00 data into my QGIS project?


2 Answers 2


I was able to solve adding an e00 file to qGIS via a roundabout route - as @MappaGnosis mentions, it is/can be a compressed format. I originally tried following this route mentioned in another question:

ogr2ogr -f "ESRI Shapefile" -a_srs EPSG:4326 pa_rivers MAJRIVRS.E00 

which produced this error:

ERROR 4: This looks like a compressed E00 file and cannot be processed directly.
You may need to uncompress it first using the E00compr library or the e00conv program.

So I found the page for e00compr, grabbed the source, uncompressed it and (note: I'm on a Mac with Xcode, command line tools, etc. installed - ymmv)

make install
cp e00conv /usr/local/bin/e00conv

and then I was able to

e00conv MAJRIVRS.E00 major_rivers.e00

after which the following command

ogr2ogr -f "ESRI Shapefile" -a_srs EPSG:4326 pa_rivers major_rivers.e00 

saved a bunch of files into a directory pa_rivers... unfortunately the coordinates in the shape file created didn't agree with my other data, but that's another question ;-)


I assume you mean .e00, which is an ArcInfo ASCII Coverage format. In which case, QGIS can read this natively, so simply add it as a layer like any other vector format.

An interchange file contains all coverage information and appropriate INFO table information in a fixed-length, ASCII format (from ESRI Help website)

The .e00 format can be compressed which is maybe why it appears to be binary in some cases. Also note that ESRI recommend using a binary format for a raster and not the .e00 format for efficiency.

  • Thanks very much, MappaGnosis. I missed the "File type" dropdown, so it wasn't showing up. I'm a total amateur at this, attempting to be self-taught. For some reason this layer is very burdensome to my system. It takes about 15 seconds to redraw the screen every time I change views--much longer than any others. Could that have to do w/ the .eOO format? Is there anything I might do about that? (Here is the file, in case you care to look at it-- dropbox.com/s/jwom1kxzz68cwm9/slbehypl%20%281%29.e00 ) Thanks again, MappaGnosis!
    – TVZ
    Commented Feb 6, 2013 at 14:57
  • The previous answer is not correct! The e00 format is a Workstation Arc/Info binary interchange format and not ASCII. Fortunately, because of GDAL, they are correct in that QGIS can read e00 if it contains a vector coverage. The caveat is that e00 files can also contain rasters. If the e00 contains a raster you may be in trouble because I am not aware of any software, other than Workstation Arc/Info that can unpack the data. Commented Feb 6, 2013 at 17:16
  • @JeffreyEvans - My answer is correct. the ArcInfo Interchange format is ASCII. Please see the edit in my post. You will also note that QGIS refers to .e00 as being ASCII - corroborating ESRI's information. Commented Feb 6, 2013 at 17:54
  • @user14838: the .e00 interchange format was only intended as an easy format to swap files between GIS software (I say 'was' as it is rather old). Your file is ASCII and therefore, I suspect that could be contributing to the slowdown as it must be interpreted every time. Have you tried converting it to another GIS format (PostGIS or even a shapefile). I can't guarantee that will help but I wouldn't normally recommend using an .e00 in the 'raw' other than to swap data. Commented Feb 6, 2013 at 18:17
  • @user14838: I did a little test on your data. Converting to another format does appear to improve performance a bit, but you have a very detailed file. Simplifying the geometry will improve performance but will also impact quality. Since you file appears to be contour data, you would also need to be very careful that simplification doesn't result in crossing of contours. Commented Feb 6, 2013 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.