0

I am working with polygon shapefiles both that I have created and that colleagues have sent me. When I try to change the transparency of the polygon through Layer Properties > Display >"Transparent: __%", the symbol in the Table of Contents on the left is changed to be more transparent, but the shapefile in the map view still has 0% transparency.

I also noticed in Layer Properties > Symbology > "Advanced: Transparency", you can "Vary feature transparency based on field values in percent." The shapefile that I created does not have much attribute data (just FID, Shape, ID), and the shapefiles from my colleagues have a few more attribute fields such as Shape_Length and Shape_Area.

However, when I toggle Symbology > "Advanced: Transparency" to different attribute fields, sometimes the transparency of the shapefile changes even though I did not change Display > "Transparent: __%". The transparency changes to some random (random to me, because I don't know why) amount. This random change is not consistent across attribute fields in different polygons.

I have tried changing the transparency through the Effects Toolbar, but I have the same problem where the symbol in the table of contents has an updated transparency but the polygon in the map still has 0% transparency.

Is there somewhere else transparency information is being stored/edited?

I learned to use ArcMap 9 and am getting back into GIS through ArcMap 10.

2
  • You have multiple accounts here, Daphne, which is why you were unable to edit your question. Please merge them by filling out the short form at gis.stackexchange.com/help/user-merge.
    – whuber
    Feb 13, 2013 at 20:53
  • Is your layer in a layer group? If so, is there transparency on the top level?
    – Fezter
    Feb 14, 2013 at 3:07

2 Answers 2

1

I just tried adding two shapefiles (one polygon over the top of another which was lines) to ArcMap 10.0 SP5. The polygons were displayed using a solid fill.

I then adjusted the transparency of the polygon layer using both the Layer Properties and Effects toolbar methods described in Setting layer transparency.

In both cases the symbol used for the polygons became transparent in both the map display and the Table of Contents.

I think you should describe your steps in more detail (be sure to start with a Blank Map) so that we can follow them to see where the software behaviour you observe deviates from what you expect.

0

I was having this trouble, and it went away when I right clicked on the polygon layer, selected Properties >> Symbology >> Advanced >> Transparency. When the little "Transparency" window popped up, I set the "Choose a Field" box to "none," and then the transparency worked either from the little slider on the effects toolbar, or from the transparency number of the Display tab in the Layer Properties dialog. I'm still beating my head against the wall trying to figure out how to set transparency based on field values, because it would be useful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.