1

I am running MapGuide Enterprise 2011 on CentOS 5 Linux. Using the Autodesk Raster FDO, I loaded a mrsid file (through the "Load file-based data" method). Whenever i try to view the layer with the mrsid file, the server crashes. most of the time it says "Segmentation Fault", but sometimes it just dies without saying anything.

Here's what the error log says when I try to view the layer:

<2011-01-14T10:39:25>   53263248        Autodesk MapGuide Studio v2.2.0.5305       198.245.206.237 Administrator
Error: An exception occurred in FDO component.
    Only MOSAIC(), CLIP() and RESAMPLE() are supported.
StackTrace:
- MgFeatureServiceHandler.ProcessOperation() line 83 file FeatureServiceHandler.cpp
- MgOpSelectFeaturesSpatial.Execute() line 110 file OpSelectFeaturesSpatial.cpp
- MgServerSelectFeatures.SelectFeatures() line 266 file ServerSelectFeatures.cpp

I've tried a few other mrsid files with the same problem. TIFF files load fine.

Anyone has any insight on this?

1
  • maybe not the most satisfying solution because the autodesk raster fdo is still broken, but Brad Nesom suggested to compile in Gdal instead and that works fine. Please see my tutorial on how to do this with the Enterprise edition: forums.autodesk.com/t5/Autodesk-MapGuide-Enterprise/…
    – janechii
    Jan 18, 2011 at 18:12

1 Answer 1

0

I think you need the fdo gdal provider. Have you looked on the fdo.org site for info?

RHEL install

Ubuntu install

4
  • Thank you for the response, Brad. I think that Autodesk Raster FDO supports MrSID also. I just cant get it working. But thank you for pointing out those guides, i will actually try this.
    – janechii
    Jan 17, 2011 at 16:36
  • Using GDAL i get the same error message, but the server doesn't crash like the Autodesk one, but nothing is displayed still
    – janechii
    Jan 17, 2011 at 23:00
  • hmm - You could go over to the fwtools.org forum and see if Frank is in. His knowledge of gdal is unprecedented. Perhaps with him helping fix it for gdal you will discover the adesk fdo fix. The only other idea I have is to use th eautodesk raster OE (object enabler) with autocad map and see if it is replicated there.
    – Brad Nesom
    Jan 17, 2011 at 23:38
  • Brad, thank you. I did get the Gdal to work, it turns out that Maestro was picky about the casing of how i spelled the name of the provider. In my providers.xml, i had OSGeo.GDAL.3.5 rather than OSGeo.Gdal.3.5. This brought up the right editor and i got everything working, though there were issues detecting spatial extents of the sid file, but that was rectified by messing with the config file bounds. thanks again!
    – janechii
    Jan 18, 2011 at 1:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.