I have been trying to publish a geoprocessing tool to our new ArcGIS for Server 10.1 with SP1. I configured the serves to not to copy data to server when publishing services.

The tool ran well and was shared as a service definition file successfully from ArcCatalog. It however always failed in publish server from ArcGIS Server Web Manager due to the following error:

ERROR 001488: The service you are trying to publish includes data but the site has been configured such that data cannot be copied to the server. ERROR 001364: Validation of service definition failed. Failed to execute (Publish Service Definition). Failed.

Can anyone help with any hints?

  • I think the problem might "@not to copy data to server when publishing services." because may some permission required if you are publishing through server. I personally think that 10.0 was the best version for ArcGIS Server
    – Sunil
    Commented Feb 15, 2013 at 5:27
  • When in doubt with ESRI, move your data to a new blank MXD. I did that and then it published perfectly like the other 20 or so services published before hand. Something got jacked up in the MXD, not sure how or why but it did. I came across this same error and none of these answers were of help. The solution ended up being simple. I had 2 things wrong and I am not sure which one fixed it but it something to keep an eye out for. First was I dumbly had a service in the MXD I was trying to publish and removed that while having the Publishing Dialogue box open. I also had one of my layers pointing Commented Mar 20, 2014 at 12:30
  • Dylan Kennard's recommendation worked for me in a similar situation. It was a 9.3 MXD and we just updated the data source of the layers. For some reason, it did not recognize that the data source was already registered. Even the Save As would not fix it. So, export layers to lyr files, import them into a new BLANK MXD and save it. Then it published with no problems.
    – user41185
    Commented Aug 19, 2015 at 15:49

2 Answers 2


It seems as the GP service you are trying to publish does need to copy some project data required for using the service. However, since you have configured the server to not allow data copying, the publishing fails. What you might need to set up is a data store. Basically, you inform the server that there is a certain workspace where the data is stored and you will make sure that the ArcGIS Server Account will have access to this place when the GP service will run and will need to access this project data.

This should make the publishing go through without copying the data yet referencing the data.

  • 2
    Just as a note - probably someone else setup your ArcGIS Server. The error message you're getting is because a setting was turned on which explicitly denies data upload when a service is published. When this is turned on you need to use a data store as Alex describes. 10.1 publishing is all about making sure the server will have access to the data, if not, the data gets moved. (except in cases like this were the Server admin says you cant move the data)
    – KHibma
    Commented Feb 15, 2013 at 16:30

I just wanted to let you know about a bit of hell I went through with a similar problem. All of my data was registered correctly, and when publishing the GP service, no warning about copying data was triggered. The GP service even executed w/o error, but was not populated the target dataset. So in doing some digging in the arcgisserver folder i found the published location of the GP and sure enough there was a fGDB copy of my SDE data on the server and that was where the GP was writing to. After tech support going on for weeks, it finally got escalated. We actually tried modifying the published GP model on the server and still had no luck. The tech person logged a bug NIM087822 for this incident.

While I agree with the other comments that its failing because you have a do not copy data parameter being enforced, I'll bet if you lifted that parameter it would publish but your data would get copied. Here is the thread I started on arcgis forums: http://forums.arcgis.com/threads/73774-Published-GP-Service-keeps-copying-data-to-server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.