I am a beginner using QGIS (1.8.0 Lisboa) on a Mac (OS X 10.6.8 Snow Leopard). I work on a file with two layers in the following sequence (top to bottom):

  • a vector polygon layer with a few outlines of various buildings in France and Italy (CRS: EPSG:4326 - WGS 84 - "on the fly" re projection is activated )
  • a Google satellite layer uploaded via open layer plugin.

Sometimes when changing the scale (scrolling in and out) the Google layer updates a little wrong in size or position compared to the polygon layer. But as soon as I "pan" the map everything reconstructs right. Now the problem I have concerns the print composer.

The result of any kind of export - pdf, or image or svg - of my map (vector layer + Google layer in the background) differs from what is shown in the preview of the print composer: the vector layer and the Google layer positions are mismatching and in a different scale. I can send some pictures showing screenshots of the print composer preview and the final results if required.

I tried almost everything:

  • new files with different CRS settings
  • "cache" update preview
  • "render" update preview
  • different paper sizes,
  • different scales,

The problem appears only using an open layer map (Google, OpenStreetMap...). If I try the same using two vector layer (shapefile) - one with the buildings, another one with the city in background - everything works out great.

...exasperating! Since it is a real important research project I would be very grateful for some help and tips.

  • do you manage to solve this issue? I'm in the same condition, trying to overlay my data over bing aerial. I even tried 1.9.0 nightly build. I filed a bug here, no response in two weeks. Good luck! – sanzoghenzo May 9 '13 at 20:56
  • this is an old thread, but i'm having the same problem with QGIS 2.2, running on iOS Maverick. I imagine it has something to do with on the fly correction? – Luis Pinto Apr 24 '14 at 12:43
  • Even if it is an old bug and underdark states she cannot reproduce the bug any more...I run into the same problem. I am working in QGIS 2.6 and Ubuntu 14.04 and I have a map with many vector layers and a background OCM Landscape, got with Openlayers Plugin. Everything is ok in the view window, but the background layer appears displaced in the map composer. The project CRS is 25829 and I would say that the problem is related to on-the-fly projecting of the OCM Landscape (which is supposed to be 3857). Any hint to solve it? I wouldn't like to change all my projecto to 3857, as the coordinates ar – Asier Nov 16 '14 at 17:50

I can confirm this bug on 1.8, here are the related tickets: http://hub.qgis.org/issues/4223 and http://hub.qgis.org/issues/6653

Testing with today's master, I cannot reproduce the problem anymore. Everything seems to work fine.

| improve this answer | |

old issue and thread but since there seems to be no answers anywhere on this problem, I thought I'd share what worked for me. Like the OP I tried everything suggested on different threads about this issue with no success. The commonly suggested method to ensure the map layer is sized to the page dimensions didn't work for me either. Funnily enough, if I use "print as PDF" in the Print composer it gives me the correct version, align just like in the print composer window. I just double checked and "export as PDF" still gives me the old misaligned version. Hope that helps someone :)

| improve this answer | |
  • Print as pdf would invoke whatever pdf print driver was installed on the machine, vs Export as pdf would use whatever is embedded into QGIS (theoretically anyway, that's the way it works in ArcGIS and most other software I know of). The solution you describe often applies to Arc as well, because their pdf creation routine lags far behind for example Adobe's (and I believe wasn't updated after a certain point because Adobe went closed standard or something if I remember right). – Chris W Mar 23 '15 at 6:20

You can try http://mapproxy.org.

Mapproxy will make "open" layers available as a WMS server.

| improve this answer | |
  • 2
    I'm not sure how this will solve the OP's issue. Could you add more information to this answer indicating the details? – Devdatta Tengshe Mar 12 '14 at 2:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.