Thought I had finally got Python, GDAL and QGIS to play nicely together but just tried to do a batch transform using a bash script to call gdalwarp and it claimed it couldn't read the libproj.dlib file. Tried the exact same transformation in QGIS and it worked. Copied the code from QGIS into bash shell and it failed. QGIS is calling the same GDAL library so I don't get this at all. Anyone got any ideas? This seems to be connected somehow, not sure how, to the EPSG codes for Swedish grids being changed every five minutes and the libraries not being up to date. That said why does QGIS manage the job when bash doesn't?

  • Getting worse. Tried entering source system as proj4 string but gdal baulked at the target epsg code and lack if lib file. It failed to transform the coordinates but it DID put the desired header into the file. From where did it get that? If it cant find the library then how the strong sweary word does it know all the metadata asked for via the epsg code? Feb 16, 2013 at 13:46

1 Answer 1


Found this:


and so added

export PROJSO=/Library/Frameworks/PROJ.framework/PROJ

to my .bash_profile

it works! I'm still running OSX 10.7 and I haven't needed this in my profile before so why I should need it now I can't say by the whole issue with paths is beginning to get a bit tiresome.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.