When I attempt to “Export as PDF” a Print Composer image, it hangs up until I press cntrl/alt/del, whereupon I learn that QGIS is not responding and needs to be closed. I’ve tried this as jpg, jpeg, and tif.

Don't know if this is related or a different issue--When I attempt to “Export as PDF”, it goes better until I open the new image in Acrobat Reader. Then I get a message that “An error exists on this page. Acrobat may not display the image correctly.” And indeed, all I get is the background raster (aerial photo) that my map is based on—none of the vectors, etc., that I have overlaid. I've seen in this forum that labels can be an issue, and to use the "new" labels from the ABC icon. Does this refer to labels created in Print Composer (which I have many of), or labels attached to layers (which I don't have any of)? I don't see any ABC icon, and don't understand what this means and cannot find further information.

  • 1
    Which version of QGIS are you using? How did you install it? It looks like you're using Windows, which version? Commented Feb 18, 2013 at 13:48
  • Sorry, Hey, I meant to tell--I'm using QGIS 1.8.0, and Windows 7. Not sure what you mean about how I installed it. I downloaded it from the QGIS website and ran the file, as best i can recall. Thanks for your interest--
    – TVZ
    Commented Feb 18, 2013 at 13:55

1 Answer 1


I'm using the same versions of the software as you are, installed the same way. I exported a simple map, about 10 sq miles worth of 2012 NAIP orthophoto in Mr Sid format, and a simple square vector layer on top of it. The process took a few minutes, and Composer was reported as Not Responding in Composer's title bar, but eventually the process did finish and the resulting PDF opened just fine and Composer returned to a normal state.

I'm assuming a more complicated map would take longer to render, you may just have to wait the process out.

  • 1
    Thanks Hey--I'll try waiting longer for the export-to-image process, which has been hanging. However, my export-to-PDF process does not take too long; however, the finished product lacks all my vector layers. Must be something different going on here--
    – TVZ
    Commented Feb 18, 2013 at 16:23
  • Just tried again on the export-to-image--waited almost an hour, and it was still working on it...
    – TVZ
    Commented Feb 18, 2013 at 17:27
  • An hour seems excessive. Are any errors being logged in the event log? Commented Feb 18, 2013 at 18:16
  • Sorry Hey--I don't know about the Event Log, and can't find any reference to one. Where do I find my event log?
    – TVZ
    Commented Feb 18, 2013 at 18:31
  • In Windows 7 you click on your start button, the right click computer, then left click Manage. This will bring up your management console. In that window you'll find an entry for Event Viewer. In the Event Viewer you'll want to scan through the Application log under Windows Logs to see if anything is popping up there from QGIS. Commented Feb 18, 2013 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.