A client has given me an XML document for the schema of an ArcGIS 9.2 Geodatabase. The final goal will be to create a version 10 version of the geodatabase but the client doesn't have version 10 yet. I have been trying to create a new geodatabase using this XML file but am not having any luck.

So far, I have tried to create a new 9.2 Geodatabase using the Create File GDB Tool. Once I have created the version 9.2 geodatabase, I tried importing the XML file by right clicking on it in ArcCatalog. Every time I import it, I get the following error:

enter image description here

I've tried importing data as well as schema only. I've also tried importing this xml file into a version 9.3 and 10.0 geodatabase. All with the same result.

XML file is about 7MB.

Does anyone know why this might be happening?


I tried running the Import XML Workspace Document tool and it displays this error. Is the XML file corrupt? How could this have happened?


The client has sent me a different XML file (the first one was opened in notepad and she thinks she may have corrupted it). However, I'm getting a seperate error now. I'm getting the following:

enter image description here

I Googled the above error and it may have something to do with the fact that the client is using ArcFM.

In answer to the comments, I've opened the xml file in Internet Explorer and Notepad++ and it is definitely an XML Workspace file. It has over 100,000 lines so I wasn't keen to read it all, but wehre it says version it does say "sde.DEFAULT". I don't have SDE set up in my office, could that be the issue?

Should the client export the data first to a file geodatabase?

  • What happens when you open the file using Internet Explorer? Feb 19, 2013 at 6:05
  • 1
    +1 to Kirk, interesting to see what it contains. Another thing that I am unsure about - when you say "ArcGIS 9.2 Geodatabase", are you sure they export a file geodatabase and not a personal geodatabase to the XML? I would suggest trying to create a personal geodatabase of 9.2 version (there is a GP tool for that in the same toolset) and try importing the XML. Feb 19, 2013 at 6:12
  • Try going to the database and select import XML workspace. Pull rather than push.
    – Brad Nesom
    Feb 19, 2013 at 6:34
  • Also you might verify it is an XML workspace rather than XML document
    – Brad Nesom
    Feb 19, 2013 at 6:36
  • 2
    OK, so they are exporting an SDE geodatabase (probably with some ArcFM behaviour) into an XML workspace document. From my searches, it seems as folk experiencing this issue are trying to get rid of the custom classes registered with the data (eg. feature classes). Unfortunately, I couldn't find anything easier so far than running some VB/C# code (support.esri.com/en/knowledgebase/techarticles/detail/17755). My suggestion would be to ask customer to export the SDE data to a file geodatabase first and then to XML workspace document. Feb 19, 2013 at 6:57

1 Answer 1


I spoke to the client about this who then passed it on to ESRI support. ESRI sent me a 10.1 geodatabase which I could open but there were some feature classes which were locked. I couldn't view the properties on them or the attribute tables. I sent it back to the client who passed it on the ESRI again. ESRI removed the ArcFM dependencies and sent me a version 10.1 Geodatabase.

It's working now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.