I am trying to import a shapefile with polygons into PostGIS (Windows 2008 server). If I import 100 polygons it works fine. If I try to import the full map of 8,100 polygons, about halfway I get an error window "Shape to PostGIS Converter has stopped working". Problem details (as shown in that window) are:

Problem signature: Problem Event Name: APPCRASH Application Name: shp2pgsql-gui.exe Application Version: Application Timestamp: 505c6e19 Fault Module Name: libglib-2.0-0.dll Fault Module Version: Fault Module Timestamp: 4e253544
Exception Code: 40000015 Exception Offset: 0004c2d8 OS Version: 6.1.7600. Locale ID: 1033 Additional Information 1: 4a99 Additional Information 2: 4a99e4ac53bd5e60be05464c3d1a217e Additional Information 3: 794a
Additional Information 4: 794abc993e1c90d5202dd7b66fde9bb9

Any suggestions as to what might be going wrong?

  • check the commit setting. you are probably loading up to much in memory before commit.
    – Brad Nesom
    Commented Feb 19, 2013 at 13:42
  • where can I change the commit setting?
    – michielz
    Commented Feb 19, 2013 at 13:50

2 Answers 2


The postgis documentation shows and example of piping in with sql chapter and section 4.3.1.
This site also mentions the -D switch for large datasets.
And here in the postgresql 9.2 documentation you can find more about the autocommit and checkpoint settings.
Inevitably someone else wil have a better answer.
I am sure many have overcome this in front of you.
Most of my experience is with oracle in this realm.
quick response to the comment made me post something to get you started.


I had same issue and found out that you have to put PostGIS Extention in every single new database which you are creating ;) enter image description here--- so check for postGIS extention just to be sure then the import/export works

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.