6

I am using QGIS and trying to import Lat/Long coordinates as delimited text layer. All points show up in my attribute table, however, only one point is displayed on the map? Any ideas?

  • Check few points.. Does all lat/lon using same location ?..Try to zoom out in QGIS..Recheck CSV file ..open this file on google earth Pro and confirmed the points.. – Sunil Feb 20 '13 at 6:42
  • @Sunil I don't have google earth pro unfortunately, but i checked everthing else. The CSV file is as simple as 2 columns one with lat in decimal degrees and other with long. thats all. I just can't figure out why i can't see all points. They points are not from the same location. Ive tried zooming in and zooming out etc. – fawnlily Feb 20 '13 at 6:50
  • 1
    If possible please upload your csv file to github (or suitable location) OR copy and past few points here.. – Sunil Feb 20 '13 at 6:59
  • @Sunil Lat Long 48.49549722 123.0003444 48.11882778 123.1360583 48.11745556 123.0172306 48.118725 123.1343611 45.08428333 122.0520361 45.15079167 122.0522028 45.01794444 122.1168806 45.3425 122.6322222 – fawnlily Feb 20 '13 at 7:14
5

Please check How to import CSV points into QGIS (Quick tutorial)

I think some settings (Like projection ,choosing delimiliter etc.) you have to make while importing CSV file in QGIS .Your points are working at my end (Please check the screenshot)

Make sure that please give column name before like lat ,lon (I have not mentioned in my case)

Screen-shot 1 :

Screen-shot 2

Let us know if you have any questions..thanks

1

You should add a header line "N E" first. Otherwise the first row does not get imported.

These headers will form the column (field) names of the attribute table. Numbers only might prevent the data from being accepted.

And make sure you don't have messed up lat and lon. lat is only valid +/- 90°, lon values +/- 180°

0

Check your scale, have you zoomed-in to the point to see if they are atop one another? Also, as stated above, it could be that the lat/lon is imported as the same. It may be that the .csv file rounded the lat/lon data and they appear as the same values in QGIS. I wrote a blog post on importing .csv lat/lon values, check it out for a tutorial on doing this correctly (with open-source data).

https://engineersportal.com/blog/2017/10/30/geospatial-analysis-using-qgis-and-open-source-data

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.