i am new in Saga Gis, i created grid- LS factor (from Rusle equation for erosis) in Saga gis and now i need to "put" it to Arcgis. How can i do this? I tried a lot of possibilities and none of them worked. Thanks

3 Answers 3


As Jay Guarneri mentionned, you can export to GeoTIFF using the Import/Export - GDAL/OGR module and GDAL: Export Raster to GeoTIFF which will create a TIF image.

Another nice way is to create a virtual raster that can be loaded in ArcGIS (verion 10 and above, I think). Virtual raster is essentially an xml file describing your raster and pointing to it. So it's not a copy, and if you update the original raster content, you'll update the vrt at the same time (except if you play with dimensions or projection). You go in Import/Export - GDAL/OGR > GDAL: Export Raster and set Format option to Virtual Raster. It's the equivalent of

gdal_translate -of VRT in.sdat out.vrt

That way you can work on your raster in saga and you just need to reload it in ArcGIS to update. No need to export it every single time.


The easiest way is to export it as a geotiff. Modules>File>GDAL/OGR>GDAL:Export Raster to GeoTIFF. Just make sure that you add ".tif" to the end of your filename (see comments below). The geotiff format can be read directly by most GIS packages.

  • i tried it, and it doesn´t work, finally i tried this: modules>file>grid>export>export esri arc/info grid and then i opened as *asc in arcgis and then in arcgis conversion tools>to raster> ascii to raster , but i am not sure if the result is good
    – Lucia
    Feb 22, 2013 at 15:25
  • If the grid was exported, it should be good. I'm curious, though, did the GeoTIFF fail on the export step or when you brought into ArcGIS? I've never had a problem with this, but it would be good to know what to look out for if I ever do. Feb 22, 2013 at 15:32
  • geotiff was exported correctly, it has *sprm at the end and i couldn´t load it to Arcgis, (i am beginner with Gis)
    – Lucia
    Feb 22, 2013 at 15:42
  • The .sprm file is the internal SAGA file, NOT the GeoTIFF. I did figure out the problem, though. It looks like SAGA did not autamatically add the file extension to the TIFF file, rendering it invisible to ArcCatalog. I must have gotten so used to entering .tif manually (I do this in ArcGIS a lot) that I forgot it doesn't tack it on. To avoid this, just add ".tif" to the end of your filename when using export to geotiff. I'll also modify the answer above to reflect this. It's also a good idea to watch where the file is being output if you aren't doing so already. Feb 22, 2013 at 15:59
  • i tried to write .tif manually and it worked :) thanks a lot
    – Lucia
    Feb 23, 2013 at 9:57

You don't have to convert. ArcGIS 10.3 supports .sdat files out of the box.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.