1

For some reason while attempting to import the com.esri.ags.portal.*, despite having the library imported in flex builder, it keeps on giving the error "import cannot be found." The strange thing is every other required import from the sample widget is not giving the same error. I tried multiple flex versions and refreshed and rebuilt, but it still has that issue.

  • Which version of the ArcGIS API for Flex are you using? – Bjorn Svensson Mar 1 '13 at 14:27
  • I am using version 4.1, but I am allowing it to recognize 3.0 in the preferences. – Carl Carlson Mar 1 '13 at 15:02
1

I'm not sure what version of Esri's Flex API (a.k.a ArcGIS API for Flex) you are using, but it sounds like it could be because of a package name change.

In version 3.0 and above of the ArcGIS API for Flex, the package name is com.esri.ags.portal http://resources.arcgis.com/en/help/flex-api/apiref/

In version 2.x, the package name was com.esri.ags.webmap http://help.arcgis.com/en/webapi/flex/apiref/

Version 3.0 and above requires Adobe/Apache Flex SDK 4.5 or later, while version 2.x only required 4.0.

  • I've tried both, but it didn't seem to fix the problem. Luckily there's no errors at the moment, so I'm ignoring the widget and examining another one. – Carl Carlson Mar 11 '13 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.