I'm currently having trouble with the georeferencer... after what appears to be successful georeferencing, the map image layer does not align to the vector data.

I'm trying to use BC Albers projection (as it's the projection of the original map image as well as the vector dataset). On-the-fly transformation is selected.

Any ideas?

  • Have you checked that the layer is added with the right CRS: Rightclick -> Set layer CRS ? Sometimes QGIS guesses wrong in this step. – AndreJ Feb 26 '13 at 6:28
  • yep, when i look at the coordinate reference system selector, it says it's BC Albers. – emac Feb 26 '13 at 7:09
  • Did you georeference by clicking points in the vector layer, or by adding coordinates read from the map? Maybe the map is in NAD27, which has an offset to NAD83. – AndreJ Feb 26 '13 at 7:14
  • I clicked the points in the vector layer. The map says it's 83, and it's at such a large scale that I don't think it would make a difference anyways. – emac Feb 26 '13 at 16:49
  • How much offset do you have? And have you confirmed the vector data against Openstreetmap or Google Imagery via openlayers plugin? Maybe you had selected a point wrong in the vector data, offsetting the resulting picture. I use around 6 to 10 points, if available, and look for the offset calculated for each point. It should not be more then 10pixels. – AndreJ Feb 26 '13 at 18:03

If you georeference by clicking points on the image and on the canvas, it is necessary to set the CRS of the georeference output to the project CRS. The CRS of the layers in the canvas can be different from that.

Unfortunately, the Georeferencer presets the output CRS to the one used last. See this ticket: http://hub.qgis.org/issues/7243


Common problem from what i have done.

Methods i use to ensure re-projection is correct:

Check layer CRS through right clicking layer and selecting set layer crs and then by way of double checking.. selecting properties and set layer crs here.

then in settings>project properties>crs.

If still nothing try in the options section of the settings.

If all else consider that the vector data may be wrong.

  • Tried it all, with no joy. Pretty sure vector data is not wrong - it's from the BC Government. I feel like maybe it's something I'm doing wrong in the settings... though they seem explanatory enough. – emac Feb 26 '13 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.