I am a Computer Analyst on a town hall. Here we have the sector A and B. Both work in ArcGIS 10 Desktop. The sector A has granted to access/edit everything. The sector A has all the privileges! The sector B can see everything. But, the sector B can only edit some Layers/Dataset. I'm having problems with the Oracle user B sector in SDE.

What I tried:

I tried to grant privileges in Oracle. To the user of sector B I grant to access/edit all. I only blocked the sector B some tables (layers). That he can't change. The user of the sector B can access the ArcGIS Desktop and can see all Layers. But, the user of sector B get an error when, by the ArcGIS Desktop, he try to edit a Layer that he has privileges. I can't understand, because I grant all the tables, including the temp tables of ArcGIS, just don't grant some tables (of some layers). The error occurs when giving a "Start editing" a layer that user B has full permission.

That is the description of the error:

" Error: No editable layers ArcGIS 10 None of the layers in your map can be edited. You cannot start an edit session on this data. Solution: Make sure that the data you want to edit is in a format that can be edited in ArcGIS and that you have the proper permissions to edit it. More information: In ArcGIS, you can edit data from shapefiles; geodatabase feature classes; standalone table formats, such as INFO or .dbf; and the attribute tables of certain rasters. If your map has data in any other format, you are unable to edit it. Make sure that the data you are attempting to edit is in one of these supported formats. If the data is not from any of these workspaces, it may be possible to export it to one of these formats to be able to edit it. Many times, you encounter this error along with layer warnings that may provide more specific reasons why the layer cannot be edited. For example, if you have data from a geodatabase in the map but the feature classes are read-only, you also receive a warning message telling you that you need to check the permissions. "


Anyone have any suggestions? How do you control your users in ArcGIS 10 Desktop? What I did wrong? Can I manage in ArcGIS Server Manager users of ArcGIS Desktop?

The idea is simple, the user sector B in ArcGIS Desktop can not access some layers. But I do not know do it.

  • 1
    Are you using SDE on top of the Oracle DB? IF so what connection method are you using?
    – Chris M
    Feb 26, 2013 at 13:30
  • We used Toad(DBA) not ArcGIS Desktop for the managing of user account. But the user don't receive a warning message to check the permissions. The SDE file is installed by default on the laptop with the credentials available.
    – user3120
    Feb 26, 2013 at 13:33
  • Chris M, I use the "Spatial Database Connection Properties", by a Oracle client. The field "Service" I put this: "sde:oracle11g:/;LOCAL=sdeblu". Feb 26, 2013 at 13:39
  • Julien, Do you speak about the Toad of the Quest.com? The DBA made the grants to me. I think he uses SQL Navigator. But I don't see how the tool will change on my problem. Feb 26, 2013 at 13:44

1 Answer 1


We generally use the Change Privilege geoprocessing tool from the Toolbox, to give editing/viewing rights over a particular dataset.

Since there are so many supporting tables that are used while editing, I would suggest that you use this GP tool to set the required privilege.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.