4

I’ve given user x the following

GRANT ALL ON ALL TABLES IN SCHEMA y TO x;
GRANT ALL ON ALL SEQUENCES IN SCHEMA y TO x;
GRANT ALL ON ALL FUNCTIONS IN SCHEMA y TO x;

However in QGIS they dont have access to check/tick the 'update existing field' button. They can chose a field to update and write an expression for its update e.g $area but the OK button remains greyed out. If I as administrator load the layer, the check/tick box appears and I can write and run expressions.

I'm sure its a permissions thing in PostGIS.

Si

update exisiting field

0

Did you test with qgis master? QGIS 1.8.0 should be still affected by issue #6120, while it's fixed in master.

  • I did have a look at master just before I left the office this afternoon and the issue is still there! – geosmiles Feb 28 '13 at 20:46
  • Can't reproduce the issue with master. If the layer doesn't have the "add attributes" capability, "create new field" is disabled and update fields is the only option (no need to select it in this case) and the "OK" button becomes enabled as soon as you create a valid expression. – jef Feb 28 '13 at 21:44
  • you quite right, in Master the 'issues' has gone I was just being slack the first time I had a look. Roll on version 1.9 (2.0)! – geosmiles Mar 1 '13 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.