I have a weird QGIS-Problem that only occurs in Ubuntu 12.04, but not in Windows 7. I've also tried this on different Ubuntu-Computers.

When I try to transform a layer with WGS84 to a different projection type (example Austrian Gauss Kruger) the result is shifted exactly 300m to the East to where it should be. This happens with both "on the fly transformation" and when I save the Layer in a different CRS!

When I save a WGS84-Layer in Gauss Kruger and I open both the new and the old layer in Ubuntu, they overlap perfectly (with on the fly-enabled). When I switch to Win7 and open both layers (the original and the one I created in Ubuntu) I can even see the 300m gap!

And ideas? Could this be a bug? Thanks!

(I am using the same EPSGs in Windows and in Ubuntu - I can also see/not see the problem, when I open the same project in Ubuntu/Windows.)


2 Answers 2


I think you ran into the same problem I had (http://osgeo-org.1560.n6.nabble.com/How-to-fix-a-CRS-definition-td5024451.html). As Andre explained:

The '+datum=hermannskogel' is hardcoded in proj: https://svn.osgeo.org/metacrs/proj/branches/4.8/proj/src/pj_datums.c with a three-parameter transformation: "hermannskogel", "towgs84=653.0,-212.0,449.0"

Seven-parameter transformations are more precise, the official parameters can be found here: http://mapref.org/GeodeticReferenceSystemsAT.html

To solve the problem, I created a custom CRS with the seven-parameter transformation.


Oh - Thank you very much, Anita! :)

Looks like the transformation parameters for a few Austrian CRS (GK BMN and Lambert) are wrong under Linux, yet correct in Win7.

Linux: GK BMN M31 EPSG: 31258

+proj=tmerc +lat_0=0 +lon_0=13.33333333333333 +k=1 +x_0=450000 +y_0=-5000000 +ellps=bessel +datum=hermannskogel +units=m +no_defs

Austria Lambert EPSG: 31287

+proj=lcc +lat_1=49 +lat_2=46 +lat_0=47.5 +lon_0=13.33333333333333 +x_0=400000 +y_0=400000 +ellps=bessel +datum=hermannskogel +units=m

Windows: GK BMN M31 EPSG: 31258

+proj=tmerc +lat_0=0 +lon_0=13.33333333333333 +k=1 +x_0=450000 +y_0=-5000000 +ellps=bessel +towgs84=577.326,90.129,463.919,5.137,1.474,5.297,2.4232 +units=m +no_defs

Austria Lambert EPSG: 31287

+proj=lcc +lat_1=49 +lat_2=46 +lat_0=47.5 +lon_0=13.33333333333333 +x_0=400000 +y_0=400000 +ellps=bessel +towgs84=577.326,90.129,463.919,5.137,1.474,5.297,2.4232 +units=m +no_defs

I used the parameters from windows as custom CRS in Linux and now it works properly! Should we report this bug somewhere?

  • According to Jürgen's answer in the conversation I linked, the error comes from th Ubuntu GDAL version, so before reporting a GDAL bug, it should be checked if it has been fixed already.
    – underdark
    Mar 3, 2013 at 10:54
  • I just tested my Ubuntu 12.04 QGIS Lisboa installation; it is built with GDAL 1.9.2 and has the same proj string as Windows QGIS Lisboa (GDAL 1.9.1) and Master (GDAL 1.9.2). I used the 'ubuntugis-unstable' ppa to install. By now, there is also a 'ubuntugis-stable' ppa, but I have not tested that.
    – AndreJ
    Mar 3, 2013 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.