I have two PCS with ostensibly the same configuration (i.e. both ArcGIS Desktop 10.0 SP5, both 4Gb RAM) yet when I load the same file geodatabase onto both and run the same large (400 element) model on both one runs perfectly (takes 1 hr 11 mins) while on the other it bails consistently with this error:

ERROR 999999: Error executing function. Invalid Topology [Topoengine error.]

If this really had invalid topology I think the same error should show on both machines so I believe the error message to be spurious and that the problem is really something to do with the underlying configurations.

To compare just the hardware configurations, in the absence of any licensing restrictions, I could use something like Belarc Advisor but this is likely to throw up so many differences that it becomes hard to distinguish those relevant to ArcGIS Desktop configuration and those that are not.

Has anybody tried to find or develop a tool that can summarise the ArcGIS Desktop and relevant hardware configuration for a machine and perhaps write that to a table so that output from two machines can be fed through Table Compare to highlight what is different?

The PatchFinder answer was a good one because it showed working machine having 10.0 SP5 only while non-working one showed a chequered history of SP2, SP4, HotFix, SP5 plus Workstation and VBA Resources. So we planned to uninstall and reinstall. Unfortunately, I cannot recall whether that plan went ahead, or the outcome.


1 Answer 1


Try PatchFinder from the ESRI Support site.

Also before you go too far down that rabbit hole you might just uninstall and reinstall ArcGIS on the problem machine. It's likely not a reproducible error if it only happens in a 400-element model.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.