I've been creating a model in Arc 10.0 for a few days now without problems. Then I added the Calculate Field Tool. I selected Make Variable --> From Parameter --> Expression. When I check off "Model Parameter" on the expression variable once it's been added to the model, save and close the model, then try to open it in Toolbox, I receive two popup errors, both saying "An error has occurred in the script on this page."

The first error says Error: Expected ')' in Line 79 Character 70 (Code 0): enter image description here

The second says The value of the property 'IntForm' is null or undefined, not a Function object in Line 465 Character 1 (Code 0): enter image description here

Both messages are referencing the following URL: file:///C:/Users/MYUSERNAME/AppData/Roaming/ESRI/Desktop10.0/ArcToolbox/Dlg/MdDlgContent.htm.

I located this article in ESRI support and followed the instructions, to no avail. (It must not be the exact same issue, as my message box doesn't reference Internet Explorer in the title). I also tried downloading SP5.

I opened the MdDlgContent.htm to take a look but that wasn't much help either because, despite some familiarity with Python and JavaScript, I am hardly a programmer.

Any help troubleshooting or resolving this issue would be greatly appreciated!!

I posted this same question in the ESRI Forums as well: http://forums.arcgis.com/threads/79448-Model-Builder-An-error-has-occurred-in-the-script-on-this-page.-MdDlgContent.htm

  • You may be encountering the problem described here. However, I've never seen it on a customised tool. For OOTB tools the workaround I use is close ArcMap, re-open it and do exactly the same thing and all works until the next reboot.
    – PolyGeo
    Mar 9, 2013 at 6:42

2 Answers 2


The issue strangely enough is caused by a dependency on Internet Explorer DLL dependencies of all strange things. It is triggered by opening the Item Description window - Try opening any tool, then opening the Item Description window for a tool, and then try re-opening that tool - the script error will occur.

A quick fix for this is to go into the Internet Explorer Internet settings (32 bit, not 64 bit version), going to Security, and then changing it from Medium-high to medium. This of course is the fastest way, and if you don't use Internet Explorer, there are no real security risks.

You can find a full writeup with a few more solutions here: https://gisnuts.com/terra/blog/2013/01/22/arcgis-geoprocessing-tools-scripting-error


I had the same problem. I just repaired ArcGIS 10: insert the ArcGIS 10 DVD and select repair. It solved my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.