I've just installed Geoserver 2.3-RC1 on windows 7 64bit and JRE 6.43 and downloaded the relevant sql extensions and Microsoft files . As instructed , I've copied "gt-jdbc-sqlserver-9.0-RC1.jar" to "C:\Program Files (x86)\GeoServer 2.3-RC1\lib" and also the x86 versions of "sqljdbc_auth.dll" and "sqljdbc_xa.dll" to "C:\Windows\System32".

I've restarted geoserver and went to Add Store and still didn't see SQL option.

I've tried doing the same with the x64 versions of the dlls , same result.

What am I missing ?!

1 Answer 1


Problem solved , Had to put the DLL in this folder:

C:\Program Files (x86)\GeoServer 2.3-RC1\webapps\geoserver\WEB-INF\lib


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.