1

I was pleasantly surprised to find very much enlarged filter support in QGIS-Dev (1.9.0_Master).

One application would be a WFS-Filter which combines $geometry and Intersect in order to load only the data from WFS which would be visible in the actual extent.

Something like this: intersects( $geometry, geomFromWKT( 'LINESTRING(765145.88 6274561.22, 776031.67 6284189.52)' ) )

Found that one in http://www.3liz.com/blog/rldhont/index.php?post/2012/11/06/Spatial-operators-in-QGIS-expression

But the above mentioned statement is not a valid expression in the "Expression string builder".

What is the correct way to phrase it?

Thanks

1

The filter code you pasted appears correct, and in fact it works when I try it in QGIS 2.8.1. If this still does not work for you, it may be a bug: you can make a free account on their bug tracker and report it there: http://hub.qgis.org/issues/

1

I ended up here when Googling for WFS filters in QGIS.

The QGIS version that I have been using (i.e. 2.14) supports the functionality requested by OP as a tick box named "Only request features overlapping the current view extent" and can be found in the "Add WFS Layer from a Server" pop up menu.

Any ideas on where to get more recent information on WFS filters used in

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.