Part of a stream is now underground so I'm trying to use split features to break the stream into two pieces. The manual says to select the feature, then the split features icon, then draw a line across the stream where I want the break. All it does is keep drawing red lines, with vertices wherever I left click, green vertices where I right click, until I crash QGIS. (Yes I toggled edit)

What should-be-obvious thing am I missing?

3 Answers 3


To use the split tool, you want to left click at least twice to create the line that will split your existing line, then after the 2nd left click you right click to finish the process.

I was kind of able to duplicate the behavior you're seeing when I left clicked to start the split line, then right clicked at it's end point. The green X would appear, and not go away until I performed a valid split. I'm using 1.8 on Windows 7.

  • Works, with one addition: the right click has to be close to the 2nd left click (on my Mac, at least), then a green X appears where the 2nd click was and the line is split. However, selecting a point to be removed, then hitting delete as in the manual doesn't work! I tried undoing edit, saving, then re-enabling edit - still no luck. Also no luck with any of the other delete x options. Another should-be-obvious goof?
    – johnsankey
    Mar 12, 2013 at 22:51
  • It isn't solved! Not only can I not delete the points at the ends of the two segments to create the gap I need, the split line feature has gone back to its prior behaviour so I can't cut the line in two places then delete feature. I can't select both sides of the previously split line to merge them either - it only selects one at a time. I don't know what is going on with QGIS in the Mac world...
    – johnsankey
    Mar 13, 2013 at 12:32
  • I think that if I hold the right button down for at least a second that it improves the odds that QGIS will accept the split, but it's still a 50/50 question. And, the only way I've found to get out of the situation is to crash QGIS (command/Q) - when it's drawing those red lines everything else seems dead.
    – johnsankey
    Mar 13, 2013 at 14:45
  • 1
    One thing that helped me was to do the two left clicks to create the points, then move the mouse off that last point before right clicking. I wish I had a Mac to test it on, but this method works for me on Windows and Linux. Mar 13, 2013 at 16:43
  • Thanks to kathadin (gis.stackexchange.com/questions/54331/…) I now now that vertex select and vector (feature) select are totally different things, and that the latter is under the View menu, not edit. Got to keep working on splitting to find what I can count on other than command/Q...
    – johnsankey
    Mar 13, 2013 at 17:14

I ran into similar issues using QGIS. I am definitely a 'newbie', but this worked for me using QGIS 2.10.1-Pisa, maybe it will help others who are new to QGIS:

  1. Open the "Advanced Interface" from the lower right hand corner
  2. Open the Advanced Digitizing toolbar: View -> Toolbars -> Advanced Digitizing
  3. Select the Edit button from the normal Digitizing toolbar (the pencil)

    You should see a red X at each vertex in your feature.

  4. Select the Split Features tool from the Advanced Digitizing toolbar.

Now you're ready to do the split:

  1. Left-click once on the first side of the feature you want to split
  2. Left-click on the other side of the feature.
  3. Right-click to confirm the edit.

    Potential Gotchas:

Once or twice I was not careful about the layer I was looking at vice the layer I had selected for edit. It's actually easy to have multiple layers in your layer list, have 1 selected for display and a different layer selected for edit. In that case, no matter how hard you try, your edit's are unlikely to work. Although it looks to you as if you are editing the layer you are looking at, you are really editing the layer selected for edit in QGIS, which do not have to be the same thing.

At first I spent a lot of time trying to ensure I was clicking right on the line when I wanted the split to occur. You don't have to. The split line has to at least include the line you want to split, but it can extend beyond it - and this is actually much easier most of the time.


@johnsankey, it sounds like those issues are occurring because you have snapping turned on. To split a feature where you like, ensure that you have snapping turned off. Otherwise, when you try and split a feature it will automatically snap to a node and try and split the feature from one node to another node instead of splitting it anywhere along the feature.

To turn snapping on or off, go to settings > snapping options

  • I had snapping turned off.
    – johnsankey
    Oct 17, 2017 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.