I have lots of column in shapefile and I need few columns.

Therefore, I am trying to select using control and trying to export but it exports all the columns (I did not get “selected records “option while exporting)

Image 1 :Selected columns

I tried using ArcToolbox (Data management tools and few more) but not getting suitable option.

Researching on Google and going through following posts:

Post 1 ,Post 2 (I do not think its proper way)

So any help will be great!!


Use can use the ArcToolbox > Data Management Tools > Fields > Delete Field geoprocessing tool. Your shapefile can be specified in the Input Table parameter. Then just choose what fields will be deleted. Remember to create a copy of the shapefile first, so you have original data!

  • Let me check that..looks like its smarter way : ) – Sunil Mar 13 '13 at 9:28
  • Just in case you don't need to create a new shapefile on disk and reuse it, consider the Layer Properties window > Fields tab to choose what fields will be visible. If you need to perform such a procedure before running some analysis, you might use the Make Feature Layer too (Data Management Tools > Layers and Table Views). – Alex Tereshenkov Mar 13 '13 at 9:28

You can turn Fields off by right-clicking on them in the table view and selecting "Turn Field off".

Or you can do it in the dataset properties -> "Fields" tab by unchecking the checkboxes next to the field name.

Fields that are turned off won´t be exported.


Please try in ModellBuilder: Use tool Make Table View (Data Management) to create a subset of fields. Then use Copy Rows (Data Management) to export these fields to new table.


There have been updates since this question was last posted. But just in case, here is a possible way to resolve and/or split your full database table into smaller feature classes or tables.

right click on the shapefile/table/feature class that has your entire data, select the fields tab, deselect/Deselect fields for the sub class or table you need, click OK, then export your data into the format you need. It should only have the columns you have chosen

Layer > Fields > "choose which fields will be visible" > OK
then Layer>Export Data

  • Welcome to GIS SE! As a new user please take the tour to learn about our focused Q&A format. – Midavalo May 29 '17 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.