3

I have a point data as observer point with field attributes for Spot, offsetA, offsetB, Radius1, Radius2, Vert1, Vert2, Azimuth1 and Azimuth 2. For the raster file- a dsm with elevation data. They have the same projection and coordinate system

But when I run the viewshed analysis I get this error:

ERROR 010067: Error in executing grid expression. No valid Observation points present. Failed to execute (Viewshed).

Any suggestions how to solve this?

4
  • Does it work if you delete the field attributes? This will show if it is a problem with the data or the attributes. Mar 14, 2013 at 14:03
  • Hi @MatthewSnape, I did. It created an output but the only attributes in the point file are ID and shape. But I need to input the parameters for SPOT, offsets, azimuths, etc. The numbers I use are the values in my analysis. Is it in the type of the fields?
    – Spencer
    Mar 14, 2013 at 14:55
  • Could it be a problem with capitalization? (e.g. "OFFSETA" vs. "offsetA") Add them back in one at a time and see which breaks the tool! (I'm looking forward to seeing the result of this, I am currently learning viewshed basics for an upcoming project and it's nice to know what might break...)
    – Erica
    Mar 14, 2013 at 18:06
  • hey @Erica! yeah.. I thought of that too. I followed the parameter settings prescribed by the tool, though it does tell you when a parameter is incorrect or does not pass a certain range.
    – Spencer
    Mar 14, 2013 at 18:49

1 Answer 1

1

For a viewshed to work the Spot values need to be above the elevation shown on the Input Raster. For example a SPOT height of 11.5m within a DTM cell of 12m will cause that error. As an alternative try using an OFFSETA instead of SPOT.

2
  • 1
    +1. Another common reason is a misunderstanding concerning coordinate systems: if ArcGIS reprojects (or fails to project) the points into locations where there are valid elevations, this error will arise.
    – whuber
    Mar 14, 2013 at 16:30
  • Thanks @Matthew! I tried changing the SPOT value as well as deleting it and using OFFSETA instead. Now, I get this error: ERROR 010160: Unable to open output raster Failed to execute (Viewshed). I think there is something wrong with my raster now..
    – Spencer
    Mar 14, 2013 at 18:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.