The following error message shows during an attempt to open geoserver url...

"HTTP ERROR: 404 NOT_FOUND RequestURI=/geoserver"

Note: I have restared the Start/Stop .bat files several times & also restarted the PC.

  • 1
    What do you see in the Geoserver Logs? Commented Mar 15, 2013 at 5:52
  • I can not open geoserver log(wrapper.log) file size is nearly 861mb...I replaced the log file with a new one... Commented Mar 15, 2013 at 6:24
  • Are you on a Windows on Linux Environment? If your running .bat files, Windows. Commented Aug 23, 2013 at 10:13

8 Answers 8


Assuming you are on windows (you mention .bat), you can do a number of things:

  1. Check the Services in windows Control Panel --> Administrative --> Services. Look for the Geoserver entry and make sure it is actually running and not disabled or stopped. You can start it from here and set it to enabled as well

  2. Make sure you are navigating correctly to the right url. It should be


or whatever port you nominated when you installed Geoserver with the windows installer

  1. Make sure no other Http Service is using the same port. First in, best dressed and the services start later and try and use that same port will fail. Development Computers fall prone to this. If so, edit you Geoserver config file at *$GEOSERVER_HOME/etc/jetty.xml* and change the port in there. Make sure Geoserver is not running then use the new port in your http request after restarting Geoserver.

I solved this with these steps on OSGeoLive 8.5

Geoserver was not able to Start after in installed Lubuntu.

i saw that there was no permission to write in the geoserver path, so i did

sudo chmod 777 -R /usr/local/lib/geoserver-2.6.1 

i started geoserver in terminal again and saw the error

java.net.BindException: Address already in use

so i looked up, which process it is, thats using port 8082 with

lsof -i :8082

in my case it was java with pid 4217


kill -9 <<pid>>

and closing firefox made the geoserver starting finally :)

hope it helps you folks

  • After all the time still working. "chmod" did the job for me (OSGeoLive 10, geoserver-2.8.3)..thanks
    – K_Man
    Commented Apr 9, 2020 at 7:53

I've had the same issue on windows.
The start up batch file would not work for me. My solution was to open a cmd.exe window running as a Administrator and navigate to the batch files,

>cd "C:\Program Files (x86)\GeoServer 2.4.5\bin

and run this


from the prompt.


Always run startup.bat from cmd prompt as an administrator. It should work.


I got the same problem in Windows 7 and GeoServer. But, in my case, the problem was related to using Tomcat 8! I uninstalled the 8 version, installed Tomcat 7 and everything went OK. Check your Tomcat version.


I "solved" this by uninstalling and installing again. Lost everything I had but it's faster to do everything anew than finding out why geoserver stopped working.


I installed java SDK 7, tomcat and geoserver. I got the same error 404. The cause of this was a port binding error for GEO Server. I changed the tomcat port to 8081 as described in this article After the restart of the PC http://localhost:8080/geoserver started to work. I found this information in wrapper.log

INFO | jvm 1 | 2015/12/25 18:41:51 | 27952 [WrapperSimpleAppMain] WARN org.mortbay.log - failed [email protected]:8080 INFO | jvm 1 | 2015/12/25 18:41:51 | java.net.BindException: Address already in use: bind

  • This might be valid for the original question, but its very hard to say without far more information. Also, note that if you are using geoserver on tomcat, is really tomcat binding on 8080, not geoserver.
    – BradHards
    Commented Dec 26, 2015 at 0:00
  • In my case the tomcat service was starting before geoserver on same port 8080. Maybe reinstalling the tomcat, would also solve this problem. I agree, there might be many causes for the 404 error.
    – the8habit
    Commented Dec 26, 2015 at 15:29
  • If you are already using tomcat, why not just deploy geoserver as a war? This is what I assumed you were doing, with something else (not tomcat or geoserver) already on 8080.
    – BradHards
    Commented Dec 26, 2015 at 21:54

on OSGEO8 :~$ /usr/local/lib/geoserver-2.4.4/bin/start_admin.sh ... enjoy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.