1

I’m using the Easy Custom Labeling plugin (with QGIS 1.8). I have one feature label which refused to show itself. It’s just not visible. When I look at the attributes table, the feature name appears in the same columns as the names of all the other features. I’ve tried moving nearby labels away from it--no difference. I’ve tried moving the feature (just to see what would happen)—nothing. If I turn on Labels in the corresponding feature layer, the label appears.

Where’s my label?

  • Are you labeling points, lines or polygons? This behavior has been related to invalid polygons before. – underdark Mar 16 '13 at 21:41
  • So far I've found it with two points. – TVZ Mar 17 '13 at 7:27
  • Now I found it happening with a line. I don't see anything invalid about any of these. – TVZ Mar 17 '13 at 7:54
  • Now I discovered the line label appearing when I changed views (panned over a ways). Each time I pan back & forth, the label appears or disappears. – TVZ Mar 17 '13 at 8:07
  • Ok, now I see that when I pan over, it changes where labels are displayed for nearby features. So if I pan to where the label was disappearing; then move the other nearby labels to other locations, the missing label appears. – TVZ Mar 17 '13 at 8:14
2

You can show all labels, regardless whether they intersect, by checking the box "Show all labels" in the Engine settings of the desired label's Layer labeling settings. The Engine settings can be found on the end of the extended options tab.enter image description here

If the missing label is still not displayed, I would try to edit the Label layer manually by overwriting the field in the attribute table with some other string.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.