My ArcGIS model used to handle .XYZ files well, but now it fails to recognize Z-value column as such - it either recognise no field at all, or it offers some defaults such as "OID".
Since the last successful run, I changed workspace and resolution of target raster (I doubt anything of it caused the problem, and I tried it with the same settings as before, and no joy here).
Do anyone have any idea what to do?

Here is a snapshot of my model:

enter image description here

My data is classical .XYZ file, with no header.

EDIT: doing the same outside the model (running the two tools used in my model manually, with intermediate multipoint feature class preserved) worked. This means the problem is not in the data (the same space delimited XYZ file from the very start), but in the model.

Some parameters:

Coordinate system: S-JTSK_Krovak_East_North (it suits the data; this is default, can be changed if the data were different)

Intermediate feature:
- type: multipoint - managed - path: blank -- AFAIK this should be necessary for sharing the model, and it shouldn't make problems as it's "managed" - but when I used the model for the first time, and successfuly, the path was set.

The rest shouldn't matter, these are mostly constants relevant to data and the results I need.

  • 1
    Maybe there is an issue with a data file instead of the model. Have you tried it against a data file that you know worked previously? – user3461 Mar 18 '13 at 18:51

I have changed the model to avoid this problem and to suit the data better. Here's my new model:

enter image description here

It has some other bugs, but there's no problem with invisible Z value.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.