My objective is really simple. I have a shapefile and would like to convert it to a Feature Class. My goal is to use HEM tools, which I think requires me to convert my shapefile of interest to a feature class.

I have a geodatabase target where I have been able to create new feature classes and feature datasets just fine. Importing a feature class is really problematic though. I get different errors depending upon the method used. Right clicking on the geodatabase gives me the "Cannot Create Output Error" implying that the output folder cannot be found....but I can see it, and the tool can see it as well or it would let me run. Right-clicking on the shapefile and exporting to a geodatabase gives me the generic 99999 error. I've tried changing path names to eliminate spacing, have tried writing to different locations to avoid permission issues (their shouldn't be any since I am an administrator). Nothing works. I'm just missing whatever it is that I need to change.

Using the Feature Class to Feature Class tool works if I write to a folder...but then my end product is another shapefile, not a feature class. I new that would happen but just did it to test out writing to my Desktop Folder.

Oddly, I've tried writing to geodatabases that I have written to before and I can't import feature classes to them either. Strange since they are populated with feature classes that I have imported in the past.

I did just upgrade from 10.0 to 10.1...not sure if that has anything to do with it.

Thanks for your help,

Vin D'Angelo

  • 1
    Have you tried using a File Geodatabase instead of a Personal Geodatabase? – PolyGeo Mar 20 '13 at 0:02
  • what sort of shape file is it? point line or polygon? – Banger Mar 20 '13 at 10:04
  • Try deleting any columns you don't need in the shape file and check for any common errors, incomplete polygons, dangling nodes etc – Banger Mar 20 '13 at 10:24
  • Thanks everyone for your suggestions. It turns out I've found a work-around. In ArcMap I just select the shapefile or feature class that I want to export to the personal geodatabase and it works just fine. Still cannot get the Feature Class-Feature Class tool to work in ArcCatalog even though the end result is the same..feature class to feature class in geodatabase. This works for now...anyone with any ideas on why something will perform in ArcMap but not in ArcCatalog? Thanks! – Vin D'Angelo Mar 22 '13 at 20:52
  • 1
    I had the same problem. You can import the shapefile into personal geodatabase using arcCatalog. It worked for me. – user25405 Jan 2 '14 at 17:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.