2

I checked "Store relative path names" in my model, but ArcGIS seems to ignore the settings - the paths are always the same as on my computer.
Plus, the "Store relative path names" unchecks automatically sometimes (I didn't find what triggers it).

How to ensure the relative paths are used? Why does ArcGIS ignore the "Store relative path names" option?

  • I've found that this setting is very inconsistent in ModelBuilder. I always check it by default, because I have found that if I don't check it, my model will fall apart if I move it, even if I have cleared any path references in the tools. Having it checked on limits that. – Cindy Jayakumar May 31 '13 at 6:24
1

I believe relative pathnames do not work in Model Builder when the Hard Drive letter changes (or across Hard Drives). Also, try setting your Output/Data-Paths to a subfolder from where the toolbox/script resides.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.