I have been using GeoServer on Apache Tomcat in Windows and I want to install GeoExplorer. It is an OpenGeo Suite tool, and its source code is found here.

I have downloaded the source code and tried to compile it using WinAnt to generate a .WAR file. However, this resulted in error messages and I am stuck. Is my way correct or what must I do to fix this problem?

The error occurred when trying to build using WinAnt. The source code was added to C:\Temp\GeoExplore, then I navigated to that directory in a Command window and issued the ant command. The resulting errors are below, and are also linked at http://notepad.cc/errorGeo

Buildfile: C:\Temp\GeoExplorer\build.xml

     [echo] pulling in submodules

C:\Temp\GeoExplorer\build.xml:26: Execute failed: java.io.IOException: Cannot run program "git.cmd": CreateProcess error=2, System cannot find the file(translated to english)
        at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
        at java.lang.Runtime.exec(Runtime.java:615)
        at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:862)
        at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:481)
        at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:495)
        at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:631)
        at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:672)
        at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:498)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.Target.execute(Target.java:390)
        at org.apache.tools.ant.Target.performTasks(Target.java:411)
        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
        at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
        at org.apache.tools.ant.Main.runBuild(Main.java:809)
        at org.apache.tools.ant.Main.startAnt(Main.java:217)
        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
Caused by: java.io.IOException: CreateProcess error=2, Sistem belirtilen dosyay?
        at java.lang.ProcessImpl.create(Native Method)
        at java.lang.ProcessImpl.(ProcessImpl.java:189)
        at java.lang.ProcessImpl.start(ProcessImpl.java:133)
        at java.lang.ProcessBuilder.start(ProcessBuilder.java:1021)
        ... 24 more

Total time: 0 seconds
  • This is difficult to help fix without knowing the exact errors. Can you please edit your question to include any error messages you've received, and let us know when the errors occurred (e.g. when generating the .WAR, or after deployment)?
    – user3461
    Commented Mar 29, 2013 at 12:37
  • I put the source code in C:\Temp\GeoExplore\. After that i ran CMD and got into that dir and i gave "ant" command. Here is the link that contains full of errors.. notepad.cc/errorGeo. THX...
    – mete7
    Commented Mar 29, 2013 at 13:17

1 Answer 1


Install Java, Git, Ant and Maven are not enough, I've succeed build that geoexplorer.war by using some git url change. Use the branch 4.1 and build using "mvn install" don't forget to build dependencies first.

  1. I assume you have installed Git, Ant, JDK (NOT JRE!!), and Maven.
  2. Clone it, type this in youre command prompt (run it twice to make sure no file missing)

    git clone https://github.com/boundlessgeo/suite.git -b r4.1

  3. You will start to clone it on youre PC. After it finish cloning, enter the directory using this command :

    cd suite

  4. Build Dependencies. When build dependencies make sure you have good internet connection, I need to build it twice because of disconected internet connection, type this command :

    git submodule update --init --recursive

  5. Build Geoexplorer.war, type this command :

    mvn install

  6. Enjoy.., Geoexplorer.war can be found on .../suite/geoexplorer/target folder

  7. Still not working or to lazy to fix it? just download this geoexplorer.zip and extract it in your webapps folder

Work as it was tested on July 14th 2014

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.