5

I'm new to QGIS and tried importing some GTFS data in the CSV format (stops.txt). The project CRS, base map CRS and GTFS CRS have all been set to Google Mercator, but the points that are supposed to appear in Boston is now plotted in the middle of the ocean.

Did I miss out on something that messed up the import/plotting?

enter image description here

enter image description here

enter image description here

enter image description here

1
  • 4
    When you define the "layers coordinate system" use WGS84 because those XY values are lat/lon. Google Mercator uses Metres so those values are being treated as metres, very close to the 0,0 origin of Googles Mercator projection. Then you can use "projection on the fly".
    – SaultDon
    Apr 3, 2013 at 20:11

2 Answers 2

8

Set the CRS of the stops layer to WGS84 EPSG:4326. The CSV data is in latitude/longitude. Google Mercator coordinates would be much bigger values. Don't forget to enable "on-the-fly" reprojection in the project properties.

1
  • 1
    Then, after what underdark explains, if you want this data in another CRS just save the layer and set the new CRS. The point is here that, as a lat/lon data it must be imported as WGS 84 EPSG:4326 in the first place, and NOT directly in the current CRS, because this fails. Mar 24, 2017 at 13:01
-3

They answered wrong, i think they didn't read very well your question.

To import CSV data into QGIS, you must the Layer menu, not the import function.

Go to Layer then Add delimited text layer then the opening window will let you manage any CSV data even the CRS and all your stops will displayed as well in their right place.

enter image description here

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.