Sorry if this is a repeat, but I couldn't find an answer here. And sorry if the answer is completely obvious, but I do appreciate your assistance with my first QGIS map.

When I try to use composer to create a printable PDF of a map I've made, clicking 'add new map', then drawing a rectangle, the map does not show up. I can add and see a north arrow image or a scale bar, either on top of or to the side of the map rectangle. I can add and adjust a frame around my map and I can change the background color. I tried to show the grid and cannot.

I downloaded a map from www.naturalearthdata.com and composer seems to work fine for me, including moving the map, changing the scale, adding the north arrow image and the scale bar.

I'm using QGIS 1.8.0-Lisboa, with Windows 8.

Any suggestions?


This might only be my opinion, but I had a lot of problems with QGIS's Print Composer especially when I had a mixture of map layers with various Coordinate Reference Systems in the same map. I used to get the dreaded 'bad allocation' error very frequently, and following that my compositions would become blank and non-functional and could only be deleted. Developing the habit of saving all new data promptly to ESRI Shapefiles and all in the same (UTM) CRS and leaving 'on the fly' turned off seems to have cleared up most of my problems. I only turn 'on the fly' on briefly now when I want a quick preview of new incoming GPS data in WGS84. Apart from that I think QGIS generally works best for me with 'on the fly' turned off.

  • yes. when i downloaded the data and inputted it into qgis the data displays normally so long as i have disabled on the fly. but normally this is not the case.
    – Ger
    Apr 8 '13 at 8:44
  • Thanks for the help. I've tried with and without 'on the fly' and it doesn't seem to matter when I go to composer, I get nothing there with this map. I tried with and without 'scale dependent rendering' as well, and got one layer (of 3) to show up in composer. I tried a map I downloaded from naturalearthdata.com and was able to get their map to show in composer with and without 'on the fly' selected. I was also able to add the important layers of my map to theirs and was able to see what I want in composer. I'll try starting from scratch and more carefully note where things go wrong. Apr 10 '13 at 1:16

First thing that strikes me is to check the scale dependant visibility in the layer properties. this may cause is not to be rendered at the selected scale. I am also presuming it is a raster base map.

  • scratch that. just downloaded the data and there is a bigger problem than what i initially thought. I think there is a flaw with the data. i have encountered this problem before. the data will display at "unusual" zooms but not fully. It could be to do with the crs.
    – Ger
    Apr 8 '13 at 8:33
  • Thanks. As I mentioned in the above reply, I tried and it made a difference, but things still didn't show correctly in composer. I'll keep trying. Apr 10 '13 at 1:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.