I'm have added a map from a WMS-server in Google Maps v2 for Android using the code provided from this site: http://www.azavea.com/blogs/labs/2013/01/wms-on-android/ . The tiles are downloaded and displayed but something is not working properly. The map looks blurry and the detail level is low.

I have tried fiddling around with the bbox parameters and if I increase the value for each point multiplying by 4, I can see a greater resolution and more details in the map but the tiles are way off.

Do I have to add some parameters to the wmsurl like resolution or something?

1 Answer 1


Make sure your projection is correct and the tile request is 256px by 256px

private static final String GEOSERVER_FORMAT =
            "http://yourApp.org/geoserver/wms" +
            "?service=WMS" +
            "&version=1.1.1" +              
            "&request=GetMap" +
            "&layers=yourLayer" +
            "&bbox=%f,%f,%f,%f" +
            "&width=256" +
            "&height=256" +
            "&srs=EPSG:900913" +
            "&format=image/png" +               

source: http://www.azavea.com/blogs/labs/2013/01/wms-on-android/

  • Thanks for your answer. The tile request is 256 and projection is 900913. I have tried using osmdroid too, where the map displayed properly. It's a huge difference comparing the level of details / resolution between osmdroid and Google Maps. I'm getting the map from the Norwegian Mapping Authority, I don't know if I have misunderstood anything: translate.google.com/…
    – user16930
    Commented Apr 9, 2013 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.