0

For me the Agent Analyst tool interface won't open.

I have ArcGIS 10.1 sp1 installed on my computer.

I have followed these steps so far:

  1. added the refresh.config.exe text file (ArcGIS 10.1 using Repast's Agent Analyst Extension - refresh.exe does not work)
  2. changed values 10.0 to 10.1 in files agent_analyst.bat and agent_analyst_run.bat in agent analyst installation folder 3- added the ArcGIS 10.1 installation path "for example C:\Program Files (x86)\ArcGIS\Desktop10.1" to environment variables ARC_JAVA & ARC_JAVAW & ARCOBJECTS_JAR (Which GIS software or plugins can perform a Cellular Automata Simulation?)

I restarted and still have had no luck (just a black box flashes up when I create a new agent analyst tool or try to edit the tool).

Is there some other step I need to do or have I done one of the above steps incorrectly?

  • Is the file named refresh.config.exe as noted above, or Refresh.exe.config as named in blah238's answer? It should be the second one, and should be located in the same directory as refresh.exe – user3461 Apr 9 '13 at 15:28
  • The file is named Refresh.exe.config and I have saved it in the 'Refresh' folder (C:\Repast 3\Agent Analyst\Refresh - is that the correct place?) which is where the Refresh.exe file is located. – lewte041 Apr 10 '13 at 1:42
  • Please help me to do numbers 2 and 3 in this instruction. I can find the files agent_analyst.bat and agent_analyst_run.bat in C:\Repast 3\Agent Analyst, but don't know how to change values. Also, I couldn't find out how to do number 3. Please explain in more detail. Thanks. – user19990 Jul 11 '13 at 13:25
  • I am trying to install Agent Analyst to my ArcGIS 10.1. I think I am almost there but the analyst does not open within ArcGIS. I have followed all the threads above and now I am able to open Agent Analyst separately outside ArcGIS and initiate it. In ArcGIS, I can't find the Cougar Model Toolbox, but when I right click any other toolbox, I do see the Agent Analyst inactive. Any suggestions? Please Advice. J M In ArcGIS](i.stack.imgur.com/FB2q0.jpg) – Juwairia Mar 4 '14 at 0:58
  • I am using 10.5 and cant get this software to work. Can someone please clarify how to change the Environment Variables. Where do I locate these? – Toni Mar 2 '18 at 14:36
3

I also got Agent Analyst to work with ArcGIS 10.2 (at least so far). I had to perform the steps noted above, but given that it was a bit confusing with some of the responses I will summarize here:

  1. Create Refresh.exe.config file with a text editor and save it along with Refresh.exe (typically in C:\Repast 3\Agent Analyst\Refresh). The Refresh.exe.config contents will be identical to the contents of the configuration file described here ("Update 2"): ArcGIS 10.1 using Repast's Agent Analyst Extension - refresh.exe does not work but you must replace newVersion="10.1.0.0" with newVersion="10.2.0.0".

  2. As noted above, edit the agent_analyst.bat and agent_analyst_run.bat files in the installation folder (C:\Repast 3\Agent Analyst) so that the folder paths contain Desktop10.2 in the folder path strings:

    rem set ARC_JAVA="C:\Program Files (x86)\ArcGIS\Desktop10.2\java\jre\bin\java"
    rem set ARC_JAVAW="C:\Program Files (x86)\ArcGIS\Desktop10.2\java\jre\bin\javaw"
    rem set ARCOBJECTS_JAR="C:\Program Files (x86)\ArcGIS\Desktop10.2\java\lib\arcobjects.jar"
    
  3. Then, edit your Environment Variables to make sure that ARC_JAVA, ARC_JAVAW, and ARCOBJECTS_JAR have a fully specified path entered for each variable (like what is in the .bat files above).

  4. Then, in my Environment Variables, I had to move ARC_JAVA (C:\Program Files (x86)\ArcGIS\Desktop10.2\java\jre\bin\java), ARC_JAVAW (C:\Program Files (x86)\ArcGIS\Desktop10.2\java\jre\bin\javaw), ARCOBJECTS_JAR (C:\Program Files (x86)\ArcGIS\Desktop10.2\java\lib\arcobjects.jar), AGENT_ANALYST (C:\Repast 3\Agent Analyst), and AGENT_ANALYST_VOL (C:) from my User Variables to my System Variables. Depending on your situation, I foresee that some people may not need to do this. If you install software and manage your system with a separate ADMIN account, then I think you will need to do this...I had to do so to get it to work.

  5. Finally, make sure you restart your system and open a fresh ArcGIS session...

I'm new to Agent Analyst so I don't know if there will be other issues down the road, but now I am at least able to see the Agent Analyst user interface when adding a new tool so it appears that everything is working well so far.

| improve this answer | |
  • These steps worked for me for 10.3.1 as of 8/23/2017. In my Refresh.exe.config file I used newVersion="10.3.0.0", and of course changed the environment variables to Desktop10.3. – Andy W Aug 23 '17 at 17:18
0

I got it to work. Instead of a general C:\Program Files (x86)\ArcGIS\Desktop10.1 path in environment variables. Give the whole direct path to the file... remember not the folder but the file. restart and it works.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.