I have exported my polygon shapefile which I got after I ran my Network Analyst into a shapefile. It has 6 buffer zones (delimited by time in increments of 10 minutes). When I check the attribute table it has my FromBreak, ToBreak and all the increments, etc.

Now I want to clip this buffer shapefile I have exported to my base shapefile (which is basically a municipality shapefile). Everything that is not included in this municipality shapefile, it's water.

Obviously I do not want my time buffer to run over water, however, when I clip the buffer to my municipality shapefile, the result shapefile loses it's buffer increments. Actually if I check the attribute table, it has the same attribute table my base shapefile had (the municipaility shapefile). How do I make the resulting shapefile after clipping to keep my buffer shapefile attributes instead?


Sounds like the layers may be out of order when you're running the Clip tool. Make sure the buffers layer is the input, and the municipal boundary is the clip feature.

I assume the buffers are in a polygon layer. Therefore, the municipal boundaries must also be a polygon.

| improve this answer | |
  • 1
    Beautiful, it actually worked. No idea what was wrong the first time. I guess I did switched around the inputs. Tho I don't think the clip should've looked the same since the municipality shapefile is obviously much bigger. Anyway, it works now, thanks! – Iuli Apr 9 '13 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.