I set up GeoServer on one of my old laptops a few weeks ago with a connection to the internet over my home cable internet line (see: http://bit.ly/e9OUNP and http://bit.ly/hj1a6J)

I'm slowly learning the ins and outs of GeoServer, GeoExplorer, and other aspects of serving maps on a website. I assumed with this set up that I (or anyone else) would be able to access my GeoServer layers in ArcMap through WMS.

I installed the OpenGeoSuite Community Edition in the default directory. I have published layers with the proper settings and check boxes enabled. I can load the layers in a GeoExplorer map embedded in a web page (see: http://bit.ly/ecpGE2).

I have tried to load these layers into ArcMap using the following request (and many variations of it): http://donmeltz.dyndns.org/geoserver/wms?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetCapabilities& but I cannot get this to work.

A couple of hours of searching has not turned up a solution to my problem yet. I'm hoping someone on here can point me in the right direction, and provide me with some ideas of what to look at next.

2 Answers 2



  • +1 That works for me, but with this error: "One or more layers failed to draw: Don's GeoSandbox - GeoServer Web Map Service: WMS service exceptions:Service Error Description: The requested Style can not be used with this layer. The style specifies an attribute of CONTOUR and the layer is: BoyScouts:BreakneckRidgeBeacnFireTower " Feb 3, 2011 at 17:48
  • Yes, that works. Now that I look at it I see my mistake. I tried it once with the :8080 in the wrong place. I had it after geoserver (as in geoserver:8080) instead of after the server IP address. Thanks! And yes, there is a problem with a couple of layers having inappropriate styles attached to them. That fix is in the works.
    – Don Meltz
    Feb 3, 2011 at 18:07

Currently your getcapabilities request is returning an error. Does it work when you are looking at the server from with in your network? However does work for me so maybe you can try that in ArcMap?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.