2

I have a problem with QGIS 1.8 with OSGEO4W installer (windows 7 - 64 bit). QGIS crash on startup, it shows the splash screen and then nothing. I have updated from an old 1.7.4 QGIS version. I have done the same procedure in a portable computer and it works fine. The problem is only in the workstation.

Is there a log file to view what the problem is?

2
  • try unistall and reinstall. is your workstation old? perhaps it is not 64 bit or windows 7.
    – Ger
    Commented Apr 17, 2013 at 15:56
  • I have tried to uninstall and reinstall QGIS and then OSGEO4W completely, but the problem doesn't solve. My workstation is relatively new, 64 bit windows 7 service pack 1, I have just controlled in control panel. Commented Apr 17, 2013 at 16:06

3 Answers 3

4

Today i stumbled on the same problem (Win 7 64-bit, QGis 1.8.0). In search of a solution i disabled all plugins (in the registry), deleted the .qgis folder, Qgis registry entries and reinstalled, but nothing helped. However, i had QGis working just fine about a week or two ago. My QGis was crashing when the splash screen displayed "Starting python" (or something similar) and i remembered that i recently upgraded from Python 2.7.2 to 2.7.4.

So, i reinstalled python 2.7.2, changed environment variables to point to python 2.7.2 and now my QGis works again. Check your python version, you might have the same problem.

2
  • Great, the problem was this, thank you very much. I have disinstalled all version of python and purged every reference in register, and now QGis start again. Now I need only to reinstall Python 2.7.2. Thank again. Commented Jun 19, 2013 at 16:18
  • @AlessandroBattistini : I'm glad you got things sorted out :) I would be grateful if you marked my answer as the accepted solution, if it helped you out :)
    – Marko
    Commented Jun 26, 2013 at 10:54
0

You may have to delete your .qgis folder. Usually under c:\windows\users\. See also: https://gis.stackexchange.com/a/57335/3438

1
  • I have deleted .qgis folder in C:\Users\Alessandro. I have also tried to remove the registry key KEY_CURRENT_USER\Software\QuantumGIS. When I launch QGIS, it re-create the folder and the key but doesn't start. Commented Apr 17, 2013 at 18:55
0

I had a similar issue and I just solved the issue with Nathan W (a real Guru!). I had a file called path.txt in my c:\ and this caused QGIS-Dev build to fail (Lisboa worked fine though).

Just rename the file (c:\path.txt) if it exists. Also install OSGEO4W in admin.

See QGIS Dev install issues for details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.