2

I'm trying to do a spatial join of a point file (created from a raster) to a polygon (target), where I am joining the GRID_CODE value from the point to the polygon. I've tried a variety of permutations, one-to-many, many-to-one, changing the order of the input files, putting in a mode and mean condition for field_map, checking the field properties (both Double), trying a multi-part to single-part conversion (data management) for both inputs, but the resulting joined field is always populated with incorrect data (as verified by looking at the point values).

For example, here is a screenshot of the correct values from the point file, highlighting the 2 (green)enter image description here

Here is a screenshot of the spatial join output highlighting that same 2 value, which I would expect to be in the same location.enter image description here

What is additionally bizarre, and might be a clue as to what is going on, is that the same field (GRID_CODE) has a different number of values (4 in the original, and 5 in the outputenter image description here

Any suggestions would be much appreciated!

0

1 Answer 1

4

This is likely to be due to the merge rules you are using (field map, right click field, merge rule).

Merge rules are at the bottom of this page.

Try setting the rule to mode to assign the polygon with the value of the most common GRID_CODE.

1
  • 1
    interesting this worked when I did the right click method, but when i went in via the "+" sign and assigned the same condition (which then appeared as a sub-condition under fieldmap>gridcode, it didn't work. thanks!
    – David Meek
    Commented Apr 18, 2013 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.