I am using QGIS v1.6 on Ubuntu 10.10.

When I use the Fetch Python Plugins menu item QGIS crashes. If I run from the terminal with sudo I get the following error:

Segmentation Fault

Does anyone know how to fix this? I have this problem on 2 installs of Ubuntu on 2 different computers.

  • I remember this from the qgis-user forum. I don't see a solution, :( ,but maybe a contact and other reading will hook you up. HTH mail-archive.com/qgis-user@lists.osgeo.org/msg05732.html I thought I remembered a thread that respoded with a solution, It seemed like renaming a file and restarting qgis was how to fix, but it has been quite a while and I was only reading. – Brad Nesom Feb 7 '11 at 14:36
  • Unfortunately non of these things worked. Reinstalling ubuntu had worked though. Maybe it is something to do with the fact I upgraded from 10.04 and didn't do a fresh install. – James S Feb 9 '11 at 8:04

The python library is probably out of sync with the python library the QGIS plugin was built on. This has been an ongoing issue and can get me more then a little irritated. Here is what I finally did:

Use QGIS from experimental. Add the nightly build to your sources in apt usually fixes this issue, but puts you on the bleeding edge, not recommended for production work. http://www.qgis.org/wiki/Download#Trunk_4 The python version and Qgis version seem to stay in sync this way.

  • 1
    I have added QGIS the way you suggest from experimental, but this still causes the segmentation error. I cannot get any plugins from the repositories due to this error. – James S Feb 8 '11 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.