4

Is there any difference in the kml script to allow different versions of Google Earth to see it ?

If I write

<?xml version="1.0" encoding="UTF-8"?>
<kml xmlns="http://earth.google.com/kml/2.1">
<Document>

</Document></kml>

How would the kml file content change if using a different Google Earth version ?

(I would like to be sure that the kml files I create are visible on currently downloadable Google Earth versions, e.g. 5 to 7.03)

I plan to use simplekml (pyPI) to generate the files. They will use GroundOverlay, NetworkLink, Region... (as created by simplekml, which I trust to do a better job than my own brain)

I tried to find any information on version changes (for Google Earth) - but have been unsuccessful. Thank you for help.

3

I think you'll be safe with any of those pretty simple, standardised elements. I'd just make it KML 2.2 (definitely supported in Google Earth 5.0 and later - back to 4.2 IIRC).

There are some elements that are "Google extensions" (in the gx: namespace) that are only supported in later versions. You can see these in the KML Reference. For example, Camera and LookAt only support <gx:ViewerOptions> in Google Earth 6.0. Using those extensions shouldn't break Google Earth (or any other KML viewer) - they'll just be ignored.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.