4

I have an ArcSDE feature class in an ArcMap MXD which I have 'joined' to a view into an external SQL database table, that is connected via an OLE DB connection.

In the MXD the join works perfectly; I can see the joined attributes when I open the attribute table of the original ArcSDE feature class.

However when I then publish the MXD to a service on the ArcGIS Server and add it to a new application it only displays the original SDE feature class attributes and not the full 'joined' attribute dataset.

Anyone seen this before or have any ideas?

5
  • What version are you using?
    – Darksanta
    Apr 19, 2013 at 11:38
  • I"ve had similar issues at 10.1.1; Can you try to do the same, but with relate instead of join? Apr 19, 2013 at 11:50
  • I am using Desktop ver 10, Server ver 10 but SDE 9.3 Apr 19, 2013 at 13:47
  • Just tried doing it via relate...no joy at all... Apr 19, 2013 at 14:05
  • Have you registered the external SQL database with ArcServer?
    – Craig
    Apr 19, 2013 at 20:02

2 Answers 2

1

Try setting up a direct connect to the external SQL table instead of OLEDB. In ArcCatalog, use "Database Connections" and use database authentication, then do join.

If that doesn't work, try to import the table into ArcSDE database using ArcToolbox "Conversion Tools > To Geodatabase > Table to Geodatabase" and then do join.

In 10.1, the tools are smarter for publishing this kind of scenario to ArcGIS Server and will tell you when the server is not going to be able to get to the data when you hit analyze. Always the next version... ; )

1

I've seen this behaviour when the joining SDE is authenticated through Windows Authentication. On server, the credentials are lost. Is this perhaps your case?

I would drop the OLE connection and switch to direct connect. It is possible 10 -> 9.3 by installing the client libs from the install media. And then, certainly, as awesomo points out, register that GDB. Best of luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.