1

I’m using the Easy Custom Labeling plugin. Useful plugin, but when I want to change the font size with the Layer Labeling Settings. Nothing changes, I can only change font size manually for each label?

Also changing it in the attribute table is not possible, as only one integer value is allowed. Removing the column and adding a new one for two integers, does not work either?

I am using QGIS 1.8.0 Lisboa

2

In the meantime I discovered a possible solution:

You can add a new column which allows more characters and fill in font size for each label. With the calculator you can fast choose the new value. Finally you have to change settings to make clear the font size will be given in the new column:

Go to "Layer" > "Labeling" > "Data Defined Settings" > "Size" and choose the new column.

There might be better solutions?

  • Actually you do not even need to add the field for the font size. You can just choose the blank field for "Size" in the Font properties of the Layer labeling settings. Afterwards you will be able to change the size in the common menue. This works also for the fonst style, color, and so on. I just discovered this due to your solution and I am so happy, that I am finally able to push that obstacle away! Thank you very much! – Gideon Jun 24 '13 at 21:21
1

Theres actually an easy fix. Something in the code is wrong but if you change the option on size to anything else like lblstring on the right hand side drop down in the styling menu , it'll start changing the size

0

Another ugly solution is to choose map units for the font size. Nevertheless, you still cannot change the font style with this solution, and you will encounter strange outputs, which means you have to try a lot until you find the appropriate size.

0

I've found an easy way to change the font size: you just need to erase the Lblsize column!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.