With QGIS 1.8 on Windows 7, I just installed PostgreSQL / PostGIS and tried to load my first data into it, a shapefile using SPIT, but failed: ERROR: Geometry type (Polygon) does not match column type (MultiPolygon).
Then I used a QGIS Vector tool "MultiPart to SingleParts", which changed the multipolygon type to "polygon" and tried to load that newly generated shapefile, which looks okay in QGIS, using SPIT once again. This time I got: ERROR: zero-length delimited identifier at or near """"

My QGIS Help dialog says that I'm using PostgreSQL Client Version 8.3.10, but I had just installed PostgreSQL 9.2 with PostGIS 2.0 using the StackBuilder from Enterprise DB.

I just found that I can load the shapefiles without error using the "PostGIS 2.0 Shapefile and DBF loader exporter" that installed from StackBuilder, and QGIS can then load that layer.

Is there some inherent incompatibility with what I just installed from Stackbuilder (to be able to create PostGIS databases) and is there a simple solution for the QGIS SPIT tool to get it operational?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.