I'm in the process of creating a polyline feature layer of tectonic plates. I'm working with WGS-84 reference system, which means the extent is +-180 in lon, and +-90 in lat. In order to create the features in a correct way, I imported a CSV file with the 4 "corners" and displayed them as points I then snap my features to when I create them.

The problems arises when I want to snap the line to the edge point. It simply doesn't want to create the line all the way, cutting it shy of the actual point.

Here's what I see: enter image description here

The coordinate is that of my cursor. The green point is (-180,-90).

The green background is another layer I used (continents) to see if there's some kind of error or a general problem, but as you can see, it sits perfectly in place.

I have tried different editor tools (line, polygon, autocomplete), but the problem persists.

I have also tried to extend that segment the the point, as well as moving a node to the point, but it doesn't edit it, and jumps back to it's previous position.

Does anyone know why this happens?

  • Maybe useful. Also what happens if you try placing a point at -180,-90 using absolute X,Y? – Matthew Snape Apr 23 '13 at 19:09
  • @MatthewSnape It doesn't execute, and the abs. xy window closes. As for the other link, all other editing and snap functionality works just fine when it's not at the edges. – HDunn Apr 23 '13 at 19:13
  • 2
    If its just four points you could try running the envelope tool – Matthew Snape Apr 23 '13 at 19:20
  • @MatthewSnape I will try it first thing in the morning, thanks. – HDunn Apr 23 '13 at 19:23
  • 1
    Well, the envelope worked, but the error was something else which I overlooked. The layer itself I was trying to edit wasn't, in fact, in wgs 84. Snapping the lines to the full extent wasn't possible because of that. – HDunn Apr 24 '13 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.