0

Sorry if this is all a bit 101, but I'm new to QGIS.

I basically have a large Arc project that I can access in QGIS for reference, so will only really be using it to identify features. For example to check the classification of a road line (which may be correct even if a lozenge on a map is incorrect, for example.)

I have my project open, but am unable to select any features from layers that are checked.

I only have the option to Deselect Features from All Layers. However, when I try to do that, nothing seems to happen. So I am unable to select any features I want to identify.

This must be something pretty simple, but some help would be much appreciated for a newbie!

Thank you.

  • If you are happy with the answer / it solved the problem please could you accept an answer so it shows as being a completed question. Cheers. – MAJ742 Apr 24 '13 at 17:56
4

Unlike Arc you need to have the layer you want to identify highlighted in the table of contents as well as turned on. I think the deselect feature isn't doing anything if you don't currently have any layers selected. Also see this answer: QGIS identify features button issue

  • Thank you - I just assumed if the checkbox was ticked, they were available to be selected. I see what you mean now, in that they have to be highlighted in TOC. – user17508 Apr 24 '13 at 13:50
  • yes, sorry I have updated my response to make it clearer – MAJ742 Apr 24 '13 at 13:57
2

Not to contradict the above answer but you do not need to have the layer you want to identify ticked. Well not entirely. If it is select then yes but the question seems to lead to interogating the data.

If you want to interogate the data click the i button. Ensure that in settings > options > map tools that you have selected top down in the identify box.

This works for intergoating data NOT selecting.

Sorry if i miss the point. Dont down vote if i have i will delete answer if it is wrong.

  • You are correct in saying that there is a possible alternative method - however it is covered in the link I included in my answer. – MAJ742 Apr 24 '13 at 17:54
  • Sorry. Did not go into the link. My apologies. – Ger Apr 25 '13 at 8:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.