I am running a few analyses with r.regression.multi in Grass 7. For a few rasters that I try to correlate, the following error comes up, however: "ERROR: Not enough valid cells available". I cannot see how the rasters I am trying to correlate in theses cases differ from the rasters where the analysis works. They match in dimension and location. Any ideas where the problem could lay?

Addition: Here a screen shot of another situation: the regression is only calculated for a certain area. enter image description here

  • 1
    Some images of those rasters might help. One possibility is that there just isn't enough variation in the explanatory variable; another is collinearity among multiple explanatory variables. – whuber Apr 24 '13 at 13:42
  • Please log in if you want to edit this question. – BradHards Apr 25 '13 at 10:37
  • Added an image to original question – Peter Apr 25 '13 at 13:14

While I suspect a simple error in the setting of the Computational region, you can use r.univar to check the univariate statistic of each raster map in order to identify the map which causes the problems. With r.univar you'll see if any NULL data layer is present.

|improve this answer|||||
  • Hi Markus! OK, so the output for |null_cells| for the example shown (image) above is |3168| for the independent var. So the bug seems indeed to lay here. The question is now how to mitigate the problem...if that is possible at all. For the examples that show ""ERROR: Not enough valid cells available" the text file produced by r.univar has headers but no values! – Peter May 29 '13 at 12:48
  • Do I get it right that your input data do not cover the same area? I guess that should match... BTW: be sure to have a recent GRASS GIS 7 version in use. – markusN Jun 2 '13 at 19:07
  • Hi Markus, thanks for replying! The input layers cover the same area, but the output (regression) only covers a small part. I will update GRASS 7 tomorrow, and see if that helps... – Peter Jun 2 '13 at 20:37
  • Thank you for the link, Markus. Grass 7 is developing into a truly powerful tool. In respect to my original problem: I am pretty sure the problem was associated with the decimals in the y/x corners of the rasters, imported into a computational area with 1m resolution. No I have integers for all x/y corners, and no problems running r.regression.multi. Best, Peter – Peter Jun 5 '13 at 9:15

OK, now it works, after setting up GRASS 7 from zero on another machine. What I did differently:

  • computational area is exactly the extend of the raster; previosuly the extend was larger than the raster,

  • imported projection through proj. file,

  • x and y corners are integers.

Which of these points made the difference, I am not sure - I think the installation of GRASS 7 and the libraries on my other computer was flawed all together.

Anyways, now it works!

Best and many thanks, once again, Peter

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.