• I've created several python scripts and created tools from them.
  • I have a custom toolbox that contains all of my tools.
  • I add this toolbox to the ArcToolbox window in ArcCatalog.
  • I want to create metadata and set parameter explanations for each tool.

I've noticed that, when I navigate to my toolbox using the ArcToolbox window, I cannot edit metadata by highlighting the tool in the toolbox window and choosing the 'Description' tab in the catalog window. I can, however, right click in the tool and choose 'Item Description', which opens another window and I can edit metadata in there.

Next, I go to the Catalog Tree Window and navigate to the location of the toolbox. In this situation, I can highlight the tool and choose the 'Description' tab and edit the metedata there. This, however, does not translate the edited metadata back to the same tool in the ArcToolbox window. If I open the tool in ArcToolbox window and highlight a parameter, I still get a description message of 'No description available'. So, it's like I have to edit the metadata twice. Once in the Arctoolbox window and then again in the Catalog Tree Window.

I've noticed this about the Description tab in ArcCatalog. It only honors selection in the Catalog Tree Window. If I a have tool selected in the ArcToolbox window, the description is still set to whatever is highlighted in the tree window, not the toolbox window.

Is this how it's supposed to work? I'm OK with only having to be able to edit metadata in the Catalog tree window, but the fact that metadata does not translate back to the same tool in ArcToolbox window is odd to me. Am I doing something wrong?

  • 1
    ArcGis version?
    – najuste
    Apr 26, 2013 at 20:13
  • Which version & service pack of ArcGIS are you using?
    – PolyGeo
    Apr 26, 2013 at 20:15
  • 1
    Also posted on ArcGIS forums: forums.arcgis.com/threads/…
    – mkennedy
    Apr 26, 2013 at 20:31
  • I'm using ArcGIS 10.1 SP1. I also experienced this in ArcGIS 10.0 SP4.
    – Mike
    Apr 26, 2013 at 20:59
  • Would you be able to revise your Question (using the edit button beneath it) with its current status including what ArcGIS for Desktop version you are currently using, please? @Hornybdd Answer below and Dale Honeycutt's on the ArcGIS Forum suggest that this appears non-reproducible at any version tested.
    – PolyGeo
    Jan 30, 2014 at 5:36

1 Answer 1


I've tried to replicate your problem in 10.1 (sp1) and I am able to edit the metadata within ArcCatalog via all routes that you have identified.

The only thing I can think of is that:

  1. you have ArcMap and ArcCatalog both open and there is some sort of locking occurring or
  2. you are attempt to edit the metadata of a tool created in an earlier version of ArcGIS and there is some sort of compatibility issue.

Try creating a tool in your latest version of ArcGIS and then attempt to edit the metadata.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.