I am trying to Resample a raster dataset to match the resolution of another dataset. I have fine resolution data on small islands (surrounded by NoData in the sea). When I re-sample the data to a resolution that is coarser than the island size, I lose this data. I need a way to re-sample to a coarse resolution, that takes into account the data on small islands, and not the NoData which takes up the majority of the new pixel size.

Any help?


  • 1
    What command are you using for resampling? – whuber Apr 28 '13 at 13:56
  • how many cells the island occupies in the original format? what is your original resolution? what is the new resolution? – Gago-Silva Apr 28 '13 at 14:39
  • is your raster dataset discrete data, such as a land-use classification or continuous data, such as satellite imagery? Which resampling algorithm are you using? Is the pixel size of the coarser resolution dataset n-times the finer resolution dataset (where n is an integer and not a floating point number). – Saleika Apr 28 '13 at 17:39
  • I am using the Resample tool in ArcGIS. There are a few Islands (and coastal areas) that are suffering, but I'm going from a 0.4deg raster to a 2deg raster. The dataset is continuous, and I've been using the Bilinear technique, however I've also tried majority to see if this makes a difference (it does not). – David Cooper Apr 29 '13 at 9:02
  • 1
    I think what I've been looking for is the aggregate tool using the mean, and not including NoData values in the calculation. It's just a bit of a hassle trying to upscale to a specific resolution as I have to give it a factor to multiply the cell size by rather than specifying '2 degrees'. Annoyingly this gives me a cell size of 2.00000000001 – David Cooper Apr 29 '13 at 12:54

If you have a spatial analyst license you can use the Block Statistics Tool (Toolbox: Spatial Analyst Tools: Neighborhood Toolset).

If you have a 3 band raster dataset, execute the Block Statistics Tool for all 3 layers. The parameter for the Block Statistic Tool should be as follows:

  • Neighborhood type: Rectangle
  • Height/Widht should be in your case 2 deg
  • Units: Map
  • Statistics type: MEAN
  • Ignore NoData in calculations: checked

After running the tool for all 3 band, stack the 3 result raster datasets to one 3 band raster dataset using the Composite Bands Tool (Toolbox: Data Management Tools: Raster Toolset).

At last you have to run the Resmple Tool with resampling type NEAREST. Cell size must be the same as you used for the Block Statistic Tool.

With that approach you don’t lose data when you “re-sample” to a coarse resolution, since it ignores the NoData in calculation. And the cell size of the coarse Resolution dataset needn't to be n times larger than the fine Resolution dataset as required by the Aggregate tool.

The radiometry of the result raster dataset will be different to the result using the bilinear resampling, but maybe it fits your needs.


If you can get your hands on 9.3 or older, the ability to ignore NoData was integrated directly into the resample tool. See the 'Search' option: http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?TopicName=Resample.

Now, it's easiest via the Aggregate tool: http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Aggregate/009z00000034000000/. This is a single step process, so that you don't have to run multiple tools to get your result, though there is neither a 'majority'/'mode' nor a 'nearest neighbor' option with this tool.

If you'd like capabilities for majority or nearest neighbor, follow Saleika's workflow.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.