4

Making some tests in Windows XP for customizing a user interface in QGIS 1.8 (see http://www.duif.net/qgis/doc/output/html/en/docs/user_manual/introduction/qgis_configuration.html#customization), I have unchecked, among other options, the Settings Menu. This means that, after restarting QGIS, there's no way of recovering the older settings because there is not already a Setting Menu. So, I cannot reload any ini file.

For your information, as a precaution, previously I have saved in a folder both the original ini file, with all the options, and the customized ini file with only some options (of course, not included here the necessary Settings Menu).

Before reinstalling QGIS (version 1,8), I would like to try other smarter options if there's any. Where and what does QGIS look at where this applications starts?

  • mhh, try to move the .qgis profile folder from your personal folder (C:/Documents.../Username) to another location. If I am right at start QGIS should create a new profile with default settings. – Curlew Apr 28 '13 at 18:58
  • Are you on Windows? – Nathan W Apr 28 '13 at 21:32
  • Yes, Nathan. I'm on Windows XP. – taurfer Apr 29 '13 at 5:23
  • I've tried also what Curlew suggests, moving the whole folder "C:\Documents and Settings[my_user_name]\.qgis" to another place. In fact, QGIS creates the .qgis folder again. This folder contains only a subfolder (in my case "gdal_pam") and the qgis.db database file. However, when I run QGIS it doesn't load the Settings Menu. – taurfer Apr 29 '13 at 5:31
3

The easiest solution is to start QGIS with the --nocustomization command line option and fix things from the GUI.

Other methods would be

QGIS up to 1.8

You can fix this in your registry by deleting either the whole section or searching and manipulating specific keys: (Use regedit to get access)

\\HKEY_CURRENT_USER\Software\QuantumGIS\QGISCUSTOMIZATION

Starting from QGIS 2.0

In case you have still access to the python console (In the Plugins menu): Enter the following command which will disable the customization:

from PyQt4.QtCore import QSettings
QSettings().setValue( '/UI/Customization/enabled', False )

If not, you're going to have to fix this in your registry by setting the key "enabled" to false: (Use regedit to get access)

\\HKEY_CURRENT_USER\Software\QuantumGIS\QGIS2\UI\customization

| improve this answer | |
0

Thanks to Mathias' clue, I have solved my problem. Mathias proposed 2 options. Unfortunately, with my customization I had also removed the Python Console. So, I have looked at the 2nd option, accesssing to the Windows Register.

I have seen HKEY_CURRENT_USER\Software\QuantumGIS\QGIS\UI, but without a "Customization" key. However, at least in my case, under HKEY_CURRENT_USER\Software\QuantumGIS\QGISCUSTOMIZATION\Customization there are some aspects that may be altered.

What I have done is: 1) To change "mSettingsMenu" from "false" to "true" in HKEY_CURRENT_USER\Software\QuantumGIS\QGISCUSTOMIZATION\Customization\Menus 2) Start QGIS 3) Load the INI file that I had stored before the customization with all the options enabled 4) Restart QGIS.

| improve this answer | |
  • I had actually no windows version running, so it was kind of a blind shot. Nice you managed still. My answer is updated (checked on windows meanwhile) – Matthias Kuhn Apr 29 '13 at 14:24
  • Perfect, Mathias! – taurfer Apr 29 '13 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.